Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059608 - kie-config-cli throws exception in remove-role-project command
Summary: kie-config-cli throws exception in remove-role-project command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER1
: 6.0.1
Assignee: Maciej Swiderski
QA Contact: Radovan Synek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 09:14 UTC by Radovan Synek
Modified: 2014-08-06 20:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:02:12 UTC
Type: Bug


Attachments (Terms of Use)
kie-config-cli output (deleted)
2014-01-30 09:14 UTC, Radovan Synek
no flags Details

Description Radovan Synek 2014-01-30 09:14:10 UTC
Created attachment 857404 [details]
kie-config-cli output

Remove-role-project command asks for repository name, then lists all available projects and lets user to choose one of them. After choosing a project, it throws an exception saying " Project <name-of-your-project> not found". In opposite, add-role-project command works as expected.

Take a look at the attached output.

Comment 1 Maciej Swiderski 2014-01-31 12:11:11 UTC
issue was caused by trying to remove roles if none yet existed and thus projects configuration was not available. Fixed it by ensuring that when no roles are assigned to project/repository an attempt to remove roles will not be allowed. Proper message will be displayed instead.

kie-wb-distributions
master:
https://github.com/droolsjbpm/kie-wb-distributions/commit/42e478a6c53fe077f3bbb3c1dcf75f5c379ce523

6.0.x:
https://github.com/droolsjbpm/kie-wb-distributions/commit/5676aeaeabc0cf9059b0036d8e29063b4fd77808

Comment 2 Radovan Synek 2014-02-20 10:56:08 UTC
Verified with BPMS-6.0.1.ER1


Note You need to log in before you can comment on or make changes to this bug.