Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059602 - Installer fails with space in JDK path on Windows
Summary: Installer fails with space in JDK path on Windows
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer, Documentation
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: CR3
: 6.1.0
Assignee: Thomas Hauser
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-30 09:05 UTC by Pavol Srna
Modified: 2015-08-03 15:57 UTC (History)
7 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-03 15:57:01 UTC
Type: Bug


Attachments (Terms of Use)
screenshot1.png (deleted)
2014-01-30 09:06 UTC, Pavol Srna
no flags Details
screenshot2.png (deleted)
2014-01-30 09:07 UTC, Pavol Srna
no flags Details

Description Pavol Srna 2014-01-30 09:05:02 UTC
Description of problem:

Please see screenshots attached.

Stack trace:
===================================================================

java.io.IOException: Cannot run program "keytool": CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessBuilder.start(Unknown Source)
        at com.redhat.installer.postinstall.KeystoreGenerator.run(KeystoreGenerator.java:69)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.izforge.izpack.installer.ProcessPanelWorker$ExecutableClass.run(ProcessPanelWorker.java:760)
        at com.izforge.izpack.installer.ProcessPanelWorker$ProcessingJob.run(ProcessPanelWorker.java:516)
        at com.izforge.izpack.installer.ProcessPanelWorker.runJob(ProcessPanelWorker.java:462)
        at com.izforge.izpack.installer.ProcessPanelWorker.run(ProcessPanelWorker.java:388)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.<init>(Unknown Source)
        at java.lang.ProcessImpl.start(Unknown Source)
        ... 11 more


==========================================================


Version-Release number of selected component (if applicable):
CR4

How reproducible:
100%


Steps to Reproduce:
1. open  CMD
2. set JAVA_HOME=C:\Program Files\Java\jdk1.7.0_45
3. set PATH=%JAVA_HOME%\bin;%PATH%
4. run the installer accepting all defaults

Comment 1 Pavol Srna 2014-01-30 09:06:43 UTC
Created attachment 857395 [details]
screenshot1.png

Comment 2 Pavol Srna 2014-01-30 09:07:43 UTC
Created attachment 857396 [details]
screenshot2.png

Comment 4 Pavol Srna 2014-01-30 10:00:20 UTC
I have reproduced the issue several times when I had a space in JDK path (e.g. C:\Program Files\Java\jdk1.7.0_45). And run successfully without the space in JDK path.

But here comes the very strange thing. I attempted to run the scenario one more time after half an hour to get the InstallationLog.txt and as a surprise I could not reproduce the issue.

Now I'm suspicious that the issue is not about a space in JDK path, but it may be the very random bug reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1053016 -- coincidence? I don't know.

Comment 5 Mark Drilling 2014-04-30 18:04:34 UTC
This is a problem with the DV6.0.0 installer also.  Just ran into it on Windows.  If you install java into a directory without spaces, all is well.

Comment 6 Van Halbert 2014-04-30 18:09:47 UTC
This is probably a common issue across all the middleware products.  Can we make sure all the related product documents are updated according?

Comment 7 belong 2014-05-01 06:10:22 UTC
This seems like a bug to me. Are we able to get this fixed for 6.1.0?


Note You need to log in before you can comment on or make changes to this bug.