Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059578 - Creating a VM from a Template without NICs might create a NIC
Summary: Creating a VM from a Template without NICs might create a NIC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-01-30 08:32 UTC by Oved Ourfali
Modified: 2014-04-01 04:56 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:19 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25158 None MERGED webadmin: Saving a dialog pressing ENTER inconsistent with clicking OK Never
oVirt gerrit 25383 None MERGED webadmin: Saving a dialog pressing ENTER inconsistent with clicking OK Never
oVirt gerrit 25457 None MERGED webadmin: Saving a dialog pressing ENTER inconsistent with clicking OK Never

Description Oved Ourfali 2014-01-30 08:32:41 UTC
Description of problem:
When creating a VM using the New VM Dialog, using a template without NICs, if after writing the VM name you presses the "Okay" button then the VM is created without NICs. However, if you just press "Enter" on the keyboard, then a NIC is added. The created NIC doesn't have any profile.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a NIC-less template
2. Create a VM from that template, pressing "Enter" on the keyboard, rather than using the mouse and pressing "Okay"

Actual results:
A NIC is created. This NIC has no profile.

Expected results:
No NIC should be created

Comment 1 Sandro Bonazzola 2014-03-04 09:17:11 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 2 Martin Pavlik 2014-03-10 13:35:20 UTC
bug is reproducible with

Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.3.master.el6ev 
vdsm-4.14.2-0.3.el6ev
libvirt-0.10.2-29.el6_5.5

Comment 3 Alona Kaplan 2014-03-10 13:42:59 UTC
Moved by mistake to on_qa.

Comment 4 Meni Yakove 2014-03-16 14:34:10 UTC
rhevm-3.4.0-0.5.master.el6ev.noarch

Comment 5 Sandro Bonazzola 2014-03-31 12:23:19 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.