Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059397 - Future parser doesn't work due to missing rgen dependency
Summary: Future parser doesn't work due to missing rgen dependency
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: puppet
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sam Kottler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1051613 1051901
Blocks: 1059391 1059395
TreeView+ depends on / blocked
 
Reported: 2014-01-29 18:44 UTC by Sam Kottler
Modified: 2014-06-18 08:14 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1051613
Environment:
Last Closed: 2014-02-10 17:47:53 UTC


Attachments (Terms of Use)

Description Sam Kottler 2014-01-29 18:44:43 UTC
+++ This bug was initially created as a clone of Bug #1051613 +++

Description of problem:
The experimental future parser in Puppet isn't working as the "rgen" dependency is missing.

Version-Release number of selected component (if applicable):
puppet-3.3.1-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. puppet apply -e 'notice([1, 2][1])' --parser future

Actual results:
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com

Expected results:
Notice: Scope(Class[main]): 2
Notice: Compiled catalog for plain.example.com in environment production in 0.31 seconds

Additional info:
ruby-rgen is packaged by Puppet Labs upstream, though I do wonder if it should be a rubygem instead, since that's how it's actually distributed by rgen.  It appears that PL have unpacked the gem and repackaged as a plain ruby package.

http://docs.puppetlabs.com/puppet/3/reference/experiments_future.html


Note You need to log in before you can comment on or make changes to this bug.