Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059386 - virtio configured, but no virtio kernel found at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1007
Summary: virtio configured, but no virtio kernel found at /usr/share/perl5/vendor_perl...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 18:27 UTC by Miguel Armas
Modified: 2018-12-05 17:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 11:18:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1059383 None None None Never

Description Miguel Armas 2014-01-29 18:27:02 UTC
Description of problem:

virt-v2v fails to migrate a VM if the VM sets colors in grub using the
"foreground" option

Version-Release number of selected component (if applicable):

virt-v2v-0.9.1-5.el6_5.x86_64
augeas-libs-1.0.0-5.el6_5.1.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Make sure you have an option "foreground" in grub.conf in a VM
2. Try to migrate the VM to libvirt
3. 

Actual results:

The migration will fail with the following error:

virtio configured, but no virtio kernel found at
/usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1007

Expected results:

The VM should be correctly migrated. Also, virt-v2v should have better error
notifications and offer an option to not remove migrated volumes if setup
virtio fails, because it could be easy to fix by hand

Additional info:

The origin of the problem is really an augeas's grub lens bug, because it
doesn't recognize the option "foreground" (but, surprisingly,  it does
recognize "background")

I did file a bug report for augeas, with id 1059383, but I think virt-v2v error message in this case is useless, and it should handle problemas with virtio capability in a more robust way...

Comment 2 tingting zheng 2014-02-19 03:24:34 UTC
I can reproduce this issue with:
augeas-libs-1.0.0-5.el6.x86_64
virt-v2v-0.9.1-5.el6_5.x86_64
libvirt-0.10.2-29.el6_5.4.x86_64

Steps:
1. Prepare a guest,add foreground to grub conf
default=0
timeout=5
foreground=ddb434
hiddenmenu

2.Usse virt-v2v to convert the geust,error shows.
# virt-v2v -ic xen+ssh://10.66.106.64 -os default xen-hvm-rhel6.2-x86_64
root@10.66.106.64's password: 
root@10.66.106.64's password: 
xen-hvm-rhel6.2-x86_64.img: 100% [=====================================================================]D 0h06m15s
virtio configured, but no virtio kernel found at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 1007.

Comment 4 Richard W.M. Jones 2014-11-18 11:18:02 UTC
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs


Note You need to log in before you can comment on or make changes to this bug.