Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059376 - Submitting a local file vmcore with 'custom core location' may stay at "Post-processing downloaded file"
Summary: Submitting a local file vmcore with 'custom core location' may stay at "Post-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server
Version: el6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Michal Toman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1061415 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 18:02 UTC by Dave Wysochanski
Modified: 2015-03-23 00:42 UTC (History)
6 users (show)

Fixed In Version: retrace-server-1.12-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 18:58:14 UTC


Attachments (Terms of Use)

Description Dave Wysochanski 2014-01-29 18:02:41 UTC
Description of problem:
Even if the file is not gzipped, it sometimes will get stuck at "Post-processing downloaded file".

Even still, you can access crash via 'retrace-server-interact <taskid> crash" even in this state.  So I'm not entirely sure whether this is a status bug or what.

This may be another variant of https://bugzilla.redhat.com/show_bug.cgi?id=1038731


Version-Release number of selected component (if applicable):
retrace-server-1.10-1.el6.noarch

How reproducible:
Unclear

Steps to Reproduce:
1. Submit a local file which is a vmcore via "custom core location"


Actual results:
The status never goes beyond "Post-processing downloaded file" even though you can access crash via 'retrace-server-interact <taskid> crash'.

Expected results:
If it gets stuck the task should eventually timeout / fail with some status.


Additional info:
I have at least one task I can point at for an example.

Comment 3 Michal Toman 2014-02-26 09:13:52 UTC
Fixed in upstream

commit eede6372a8492d543aa86f513b3dbf0be0a99ab9
Author: Michal Toman <mtoman@redhat.com>
Date:   Tue Feb 25 16:27:47 2014 +0100

    do not die trying to chmod() a hardlink
    
    Signed-off-by: Michal Toman <mtoman@redhat.com>

Comment 4 Michal Toman 2014-02-26 09:14:29 UTC
*** Bug 1061415 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-02-27 13:47:11 UTC
retrace-server-1.11-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.11-1.el6

Comment 6 Fedora Update System 2014-03-01 07:12:13 UTC
Package retrace-server-1.11-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing retrace-server-1.11-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0687/retrace-server-1.11-1.el6
then log in and leave karma (feedback).

Comment 8 Dave Wysochanski 2014-03-07 20:42:17 UTC
This looks fixed to me.

Comment 9 Fedora Update System 2014-07-31 11:52:54 UTC
retrace-server-1.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.12-2.el6

Comment 10 Fedora Update System 2014-08-15 18:58:14 UTC
retrace-server-1.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.