Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059345 - create /run/lock when used with mock
Summary: create /run/lock when used with mock
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 16:57 UTC by Zenon Panoussis
Modified: 2014-06-18 00:37 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1045849
Environment:
Last Closed: 2014-05-27 13:28:14 UTC


Attachments (Terms of Use)

Description Zenon Panoussis 2014-01-29 16:57:18 UTC
+++ This bug was initially created as a clone of Bug #1045849 +++

Description of problem:
try to build a package using opencryptoki-devel, I see weird failure in mock and koji :

DEBUG util.py:266:  Error unpacking rpm package opencryptoki-3.0-6.fc20.x86_64
DEBUG util.py:266:  error: unpacking of archive failed on file /var/lock/opencryptoki: cpio: mkdir
DEBUG util.py:266:  error: opencryptoki-3.0-6.fc20.x86_64: install failed


after looking for it, the problem is the following :
# ls -l  /var/lock 
lrwxrwxrwx. 1 root mockbuild 11 22 déc.  15:04 /var/lock -> ../run/lock

opencryptoki do expect /var/lock to exist, from what I see, and this work fine on a regular system. 

Following the policy 
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d

I see that systemd rpm should create the directory on installation but do not do it, despites being the one that create it on boot :

/usr/lib/tmpfiles.d $ grep '/run/lock ' legacy.conf
d /run/lock 0755 root root -

$ rpm -qf legacy.conf 
systemd-208-9.fc20.x86_64

--- Additional comment from Zbigniew Jędrzejewski-Szmek on 2013-12-24 15:53:26 EST ---

I pushed a change to git which allows tmpfiles to be executed after boot. Now the rpm will have to be modified to execute tmpfiles on rpm installation or reinstallation. /run/lock will be created, and this should fix your problem.

--- Additional comment from Jaromír Cápík on 2014-01-14 10:58:05 EST ---

Bug 1052932 is related ...

--- Additional comment from Fedora Update System on 2014-01-14 20:26:17 EST ---

systemd-208-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/systemd-208-11.fc20

--- Additional comment from Fedora Update System on 2014-01-16 02:02:26 EST ---

Package systemd-208-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-208-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0902/systemd-208-11.fc20
then log in and leave karma (feedback).

Comment 1 Zenon Panoussis 2014-01-29 16:58:55 UTC
Same problem on el7.


Note You need to log in before you can comment on or make changes to this bug.