Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059304 - systemd-tmpfiles-setup.service fails on selinux disabled machines
Summary: systemd-tmpfiles-setup.service fails on selinux disabled machines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 15:38 UTC by Zing
Modified: 2015-03-10 02:58 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.13.1-116.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 02:58:41 UTC


Attachments (Terms of Use)

Description Zing 2014-01-29 15:38:28 UTC
Description of problem:
systemd-tmpfiles-setup.service fails on selinux disabled machines

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-18.fc21.noarch

Steps to Reproduce:
1. disable selinux
2. reboot

Actual results:
systemd-tmpfiles-setup.service fails

Expected results:
systemd-tmpfiles-setup.service ok

Additional info:

systemd-tmpfiles-setup.service                                                            loaded failed failed    Create Volatile Files and Directories


systemd-tmpfiles-setup.service - Create Volatile Files and Directories
   Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-setup.service; static)
   Active: failed (Result: exit-code) since Wed 2014-01-29 10:30:05 EST; 32s ago
     Docs: man:tmpfiles.d(5)
           man:systemd-tmpfiles(8)
  Process: 483 ExecStart=/usr/bin/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev (code=exited, status=1/FAILURE)
 Main PID: 483 (code=exited, status=1/FAILURE)

Jan 29 10:30:05 rawhide systemd-tmpfiles[483]: [/usr/lib/tmpfiles.d/selinux-policy.conf:4] Write file requires argument.
Jan 29 10:30:05 rawhide systemd[1]: systemd-tmpfiles-setup.service: main process exited, code=exited, status=1/FAILURE
Jan 29 10:30:05 rawhide systemd[1]: Failed to start Create Volatile Files and Directories.
Jan 29 10:30:05 rawhide systemd[1]: Unit systemd-tmpfiles-setup.service entered failed state.

Comment 1 Zing 2014-01-29 15:46:52 UTC
A couple of minutes later:

# sc status systemd-tmpfiles-clean.service
systemd-tmpfiles-clean.service - Cleanup of Temporary Directories
   Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-clean.service; static)
   Active: failed (Result: exit-code) since Wed 2014-01-29 10:44:55 EST; 1min 6s ago
     Docs: man:tmpfiles.d(5)
           man:systemd-tmpfiles(8)
  Process: 888 ExecStart=/usr/bin/systemd-tmpfiles --clean (code=exited, status=1/FAILURE)
 Main PID: 888 (code=exited, status=1/FAILURE)

Jan 29 10:44:55 rawhide systemd-tmpfiles[888]: [/usr/lib/tmpfiles.d/selinux-policy.conf:4] Write file requires argument.
Jan 29 10:44:55 rawhide systemd[1]: systemd-tmpfiles-clean.service: main process exited, code=exited, status=1/FAILURE
Jan 29 10:44:55 rawhide systemd[1]: Failed to start Cleanup of Temporary Directories.
Jan 29 10:44:55 rawhide systemd[1]: Unit systemd-tmpfiles-clean.service entered failed state.

Comment 2 Daniel Walsh 2014-01-29 19:56:08 UTC
fixed in selinux-policy-3.13.1-20.fc21  If you edit /lib/tmpfiles.d/selinux-policy.conf

w /sys/fs/selinux/checkreqprot - - - 1

Should be

w /sys/fs/selinux/checkreqprot - - - - 1

ANd I think that will fix the problem.

Comment 3 Jaroslav Reznik 2015-03-03 17:11:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 4 Fedora Update System 2015-03-06 22:08:37 UTC
selinux-policy-3.13.1-116.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-116.fc22

Comment 5 Fedora Update System 2015-03-09 08:37:33 UTC
Package selinux-policy-3.13.1-116.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-116.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3508/selinux-policy-3.13.1-116.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-03-10 02:58:41 UTC
selinux-policy-3.13.1-116.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.