Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059188 - pcap files are not opened by Wireshark when double-clicked in GNOME Nautilus
Summary: pcap files are not opened by Wireshark when double-clicked in GNOME Nautilus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 20
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 11:52 UTC by Kenneth Soerensen
Modified: 2014-02-18 13:43 UTC (History)
4 users (show)

Fixed In Version: wireshark-1.10.5-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-18 13:27:49 UTC


Attachments (Terms of Use)

Description Kenneth Soerensen 2014-01-29 11:52:36 UTC
Description of problem:
When double-clicking on a pcap/pcapng file in Nautilus the file is not opened by Wireshark but an error is displayed.

Also when right-clicking and viewing Properties and Open With, Wireshark is not on the list of applications.

The problem seems to be related to the path used to find the executable for applications used to open files in Nautilus. The problem seems to be fixed either by adding a symlink from /usr/bin/wireshark to /usr/sbin/wireshark or by adding the absolute path to Exec and TryExec in /usr/share/applications/wireshark.desktop . The last option is preferred.


Version-Release number of selected component (if applicable):
wireshark-gnome-1.10.5-2.fc20.x86_64

How reproducible:
The problem was gone for a while but now it stays.

Steps to Reproduce:
1. Double-click on a pcap/pcapng file in Nautilus
2.
3.

Actual results:
The following dialog is displayed:
Could not display “test.pcapng”.
There is no application installed for “Packet Capture (PCAPNG)” files.
Do you want to search for an application to open this file?


Expected results:
Wireshark should open the file.


Additional info:
Suggested patch:
--- /tmp/wireshark.desktop	2014-01-29 12:48:16.281229189 +0100
+++ /usr/share/applications/wireshark.desktop	2014-01-29 12:48:52.513404049 +0100
@@ -70,8 +70,8 @@
 Comment[fr]=Analyseur de trafic réseau
 Comment[sv]=Nätverkstrafikanalysator
 Icon=wireshark
-TryExec=wireshark
-Exec=wireshark %f
+TryExec=/usr/sbin/wireshark
+Exec=/usr/sbin/wireshark %f
 Terminal=false
 MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;
 # Category entry according to:

Comment 1 Peter Lemenkov 2014-01-29 12:03:20 UTC
(In reply to Kenneth Soerensen from comment #0)

> Suggested patch:
> --- /tmp/wireshark.desktop	2014-01-29 12:48:16.281229189 +0100
> +++ /usr/share/applications/wireshark.desktop	2014-01-29 12:48:52.513404049
> +0100
> @@ -70,8 +70,8 @@
>  Comment[fr]=Analyseur de trafic réseau
>  Comment[sv]=Nätverkstrafikanalysator
>  Icon=wireshark
> -TryExec=wireshark
> -Exec=wireshark %f
> +TryExec=/usr/sbin/wireshark
> +Exec=/usr/sbin/wireshark %f
>  Terminal=false
>  MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-
> snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;
> application/x-radcom;application/x-etherpeek;application/x-visualnetworks;
> application/x-netinstobserver;application/x-5view;
>  # Category entry according to:

Good catch! Thanks, Kenneth. I'll provide a new build shortly.

Comment 2 Fedora Update System 2014-01-29 14:24:48 UTC
wireshark-1.10.5-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wireshark-1.10.5-3.fc20

Comment 3 Fedora Update System 2014-01-29 14:24:58 UTC
wireshark-1.10.5-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wireshark-1.10.5-3.fc19

Comment 4 Kenneth Soerensen 2014-01-29 14:30:17 UTC
Hi Peter

Thank you for the quick response.

The new build fixes the problem.

/Kenneth

Comment 5 Fedora Update System 2014-01-30 03:32:13 UTC
Package wireshark-1.10.5-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wireshark-1.10.5-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1753/wireshark-1.10.5-3.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-02-18 13:27:49 UTC
wireshark-1.10.5-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-02-18 13:43:40 UTC
wireshark-1.10.5-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.