Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059156 - Move out downstream specific vdc_options changes into rhevm-setup-plugins
Summary: Move out downstream specific vdc_options changes into rhevm-setup-plugins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Tareq Alayan
URL:
Whiteboard: integration
Depends On: 1059411
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-29 10:00 UTC by Alon Bar-Lev
Modified: 2014-09-18 23:47 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-09 13:31:21 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0653 normal SHIPPED_LIVE rhevm-setup-plugins bug fix and enhancement update 2014-06-09 17:21:48 UTC

Description Alon Bar-Lev 2014-01-29 10:00:48 UTC
Following changes should not be patched into rhevm but be done using rhevm-setup-plugin package.

This reduces our last remain downstream patches that are not packaging related.

---

== branding: set package names for guest agent ==

-select fn_db_add_config_value('AgentAppName','ovirt-guest-agent-common,ovirt-guest-agent','general');
+select fn_db_add_config_value('AdvancedNFSOptionsEnabled','true','3.1');
+select fn_db_add_config_value('AdvancedNFSOptionsEnabled','true','3.2');
+select fn_db_add_config_value('AdvancedNFSOptionsEnabled','true','3.3');
+select fn_db_add_config_value('AgentAppName','rhev-agent,rhevm-guest-agent,rhevm-guest-agent-common,RHEV-Agent','general');
+select fn_db_update_config_value('AgentAppName','rhev-guest-agent-common,rhevm-guest-agent,rhevm-guest-agent-common,RHEV-Agent','general');

== branding: 'rhevm' management bridge ==
-select fn_db_add_config_value('AllowClusterWithVirtGlusterEnabled','true','general');
+select fn_db_add_config_value('AllowClusterWithVirtGlusterEnabled','false','general');

-select fn_db_add_config_value('ManagementNetwork','ovirtmgmt','general');
+select fn_db_add_config_value('ManagementNetwork','rhevm','general');

== backend: Cluster with Virt or Gluster support ==

-select fn_db_add_config_value('AllowClusterWithVirtGlusterEnabled','true','general');
+select fn_db_add_config_value('AllowClusterWithVirtGlusterEnabled','false','general');

core: Allow bridges report for 3.1 cluster level
+select fn_db_add_config_value('SupportBridgesReportByVDSM','true','3.2');
+select fn_db_add_config_value('SupportBridgesReportByVDSM','true','3.3');

-select fn_db_update_config_value('SupportBridgesReportByVDSM','false','3.1');
+select fn_db_update_config_value('SupportBridgesReportByVDSM','true','3.1');

== core: disable migration of CPU pinned VM's ==

+select fn_db_update_config_value('CpuPinMigrationEnabled','false','general');

== core: Add RHEL-6.4.0 machine type for 3.2 and 3.3 ==

+select fn_db_add_config_value('EmulatedMachine','rhel6.0.0','3.0');
+select fn_db_add_config_value('EmulatedMachine','pc-0.14','3.1');
+select fn_db_add_config_value('EmulatedMachine','rhel6.4.0','3.2');
+select fn_db_add_config_value('EmulatedMachine','rhel6.4.0','3.3');

== db: support only cluster emulation level of RHEL ==

-select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.2.0,pc-1.0','3.0');
-select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.3.0,pc-1.0','3.1');
-select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.4.0,pc-1.0','3.2');
-select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.4.0,pc-1.0,pseries','3.3');
-select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.5.0,pc-1.0,pseries','3.4');
+select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.2.0','3.0');
+select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.3.0','3.1');
+select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.4.0','3.2');
+select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.5.0','3.3');
+select fn_db_add_config_value('ClusterEmulatedMachines','rhel6.5.0','3.4');

Not sure what these are doing in the bridge setting, eli?:

-INSERT INTO network (id,name,description,storage_pool_id) SELECT v_id_0009, 'ovirtmgmt', 'Management Network', v_storage_pool_id;
+INSERT INTO network (id,name,description,storage_pool_id) SELECT v_id_0009, 'rhevm', 'Management Network', v_storage_pool_id;

Comment 2 Tareq Alayan 2014-02-23 15:02:08 UTC
Hi Alon, 
How can i verify this?

Comment 3 Alon Bar-Lev 2014-02-23 15:44:20 UTC
(In reply to Tareq Alayan from comment #2)
> Hi Alon, 
> How can i verify this?

if no regression all is ok.

it is a move of code from one place to another.

Comment 7 errata-xmlrpc 2014-06-09 13:31:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0653.html


Note You need to log in before you can comment on or make changes to this bug.