Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059141 - every update of tzdata or glibc replaces /etc/localtime
Summary: every update of tzdata or glibc replaces /etc/localtime
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tzdata
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Patsy Franklin
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 09:40 UTC by Harald Reindl
Modified: 2014-01-29 13:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-29 12:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Harald Reindl 2014-01-29 09:40:40 UTC
every single update of tzdata or glibc on RHEL5 replaces /etc/localtime with UTC independent if it contains a different timezone or a symlink
_________________________________

current result

cat /etc/localtime 
TZif2UTCTZif2UTC                                                                                                                
UTC0 
_________________________________

expected result:

don't mangle
/etc/localtime -> ../usr/share/zoneinfo/Europe/Vienna

Comment 1 RHEL Product and Program Management 2014-01-29 10:32:55 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 2 Petr Machata 2014-01-29 12:53:21 UTC
This is as designed.  To support separately-mounted /usr, we install a trigger that copies over the new version of zone file, instead of simply using a symlink.  Use system-config-date to configure which time zone /etc/localtime should be replaced with.

Comment 4 Harald Reindl 2014-01-29 13:03:17 UTC
RHEL6/RHEL7 does not behave that way
don't get me wrong but that is *wrong* designed

"system-config-date" pulls 96 packages as dependencies
so that is hardly a solution on stripped down, headless servers

Comment 5 Petr Machata 2014-01-29 13:11:02 UTC
Editing /etc/sysconfig/clock should work as well, that's where the triggers look to do their thing.

I though RHEL 6 behaved the same way, but I may be wrong.  Patsy, can you please check this out?

RHEL 7 indeed does use symlinks.

Comment 6 Harald Reindl 2014-01-29 13:16:09 UTC
i do not know hat RHEL6 is using out of the box because i configured the RHEL5/6/7 machines with the same config files and only RHEL5 destroys the symlink by UTC which is odd because the whole internet refers to /etc/localtime 

it needed a very long time to realize when and with which package updates this is always changed on RHEL5 - "VMware Data Recovery" as example is using CentOS5 as base and the backend is not much happy when the timezone changed in a way that it is 1 or 2 hours wrong (summer/winter) and differs with the vCenter server


Note You need to log in before you can comment on or make changes to this bug.