Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059105 - oo-accept-node will still check the apache configs for mod_rewrite frontend when using vhost frontend plugin
Summary: oo-accept-node will still check the apache configs for mod_rewrite frontend w...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Rajat Chopra
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1112446 1132963
TreeView+ depends on / blocked
 
Reported: 2014-01-29 07:59 UTC by Meng Bo
Modified: 2016-08-29 17:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1112446 1132963 (view as bug list)
Environment:
Last Closed: 2014-10-10 00:46:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2014-01-29 07:59:29 UTC
Description of problem:
Run oo-accept-node on node to check the apache config issue on node, it will only return the issues when the node using mod_rewrite plugin.
That means for nodes which running with vhost plugin will never failed the httpd config check by oo-accept-node.

Version-Release number of selected component (if applicable):
devenv_4295

How reproducible:
always

Steps to Reproduce:
1. Launch instance and let it using vhost frontend plugin
2. Make the httpd config mismatch with gear
eg, 
copy the 52e89ec6070b084933000006_bmengdev_0_php1.conf and 52e89ec6070b084933000006_bmengdev_php1/ back after gear deleted.
or
delete the existing config files for running gear.
3. Run oo-accept-node -v

Actual results:
It will pass the checking.

Expected results:
Should fail since the http config does not match the gear.

Additional info:
Set it to low severity since for the online product, mod_rewrite plugin is using for most of the nodes.

Comment 1 Meng Bo 2014-08-21 06:31:50 UTC
Raise the severity since the vhost plugin will be used by default. And seems the behavior is a little different for now, but the oo-accept-node will still only check the mod_rewrite httpd configs.

# oo-accept-node -v
INFO: loading node configuration file /etc/openshift/node.conf
INFO: loading resource limit file /etc/openshift/resource_limits.conf
INFO: finding external network device
INFO: checking that external network device has a globally scoped IPv4 address
...
INFO: checking 1 user accounts
INFO: checking application dirs
INFO: checking system httpd configs
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/aliases.db
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/idler.db
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/nodes.db
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/sts.db
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/aliases.txt
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/idler.txt
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/nodes.txt
FAIL: No such file or directory - /etc/httpd/conf.d/openshift/sts.txt
FAIL: Gear has a web framework cartridge but no Apache configuration: 53f5c91b6db2e685f9000075

Comment 3 Meng Bo 2014-08-22 03:03:06 UTC
The bug got partial fixed, it will not check the mod_rewrite apache configs when using vhost plugin.

But it still cannot find out the configuration issue for vhost plugin, as comment#0 said.

Remove the gear apache config 53f6e9ef7828706bb4000001_bmengsdev_0_php54.conf under /var/lib/openshift/.httpd.d/ and run oo-accept-node -v. 

It will report pass, and it should figure out the apache config mis-match.

Comment 4 Rajat Chopra 2014-08-22 05:07:28 UTC
It is correct that all the functionality of accept-user that existed for mod-rewrite, has not been imported to vhost. This is one of them. If you delete the gear's config, then we will not be able to report it.  
Some checks remain, like if we have a config but the gear does not exist, then it will be reported.
A new user story will cover the improvements meant for oo-accept-node in vhost mode.

Marking this ON_QA.

Comment 5 Meng Bo 2014-08-22 05:36:23 UTC
According to comment#4, move the bug to verified.

Comment 6 Meng Bo 2014-11-11 10:32:43 UTC
Hi Rajat,

Do we have a plan for the new user story about checking frontend config via oo-accept-node under vhost mode?

Thanks.

Comment 7 Rajat Chopra 2016-08-29 17:48:27 UTC
Closing the NeedInfo.


Note You need to log in before you can comment on or make changes to this bug.