Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1059076 - firefox-26.0-5.fc20 breaks flash plugin
Summary: firefox-26.0-5.fc20 breaks flash plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 05:47 UTC by Sergio Monteiro Basto
Modified: 2014-02-12 14:41 UTC (History)
5 users (show)

Fixed In Version: xulrunner-27.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-06 03:43:06 UTC


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2014-01-29 05:47:05 UTC
Description of problem:
https://bugzilla.redhat.com/show_bug.cgi?id=843583#c40

after update from -4 to -5 flash doesn't work correctly in many sites , in some flickers in other just don't render any thing 

Version-Release number of selected component (if applicable):
firefox-26.0-5.fc20

How reproducible:

https://bugzilla.redhat.com/show_bug.cgi?id=843583#c46


Additional info:
from -4 to -5 enable gstreamer but also 

Standalone firefox package without need of xulrunner

http://pkgs.fedoraproject.org/cgit/firefox.git/commit/?h=f20&id=875d0c0e871da050a4cfe44c0afae09c1ad739e4

I suspect this one because , I try a copr build with gstreamer disable and still have the problem , also this is a big patch. 

I will try revert it .

Comment 1 Jan Horak 2014-01-29 15:08:37 UTC
With firefox 26.0-5 we introduced using system cairo library. This might be related to your problem as long as it is library used for drawing, please try to update to firefox-26.0-8:
https://copr.fedoraproject.org/coprs/xhorak/firefox-without-gstreamer/
and let me know if that fixed your problem.

Comment 2 Sergio Monteiro Basto 2014-01-29 18:41:31 UTC
yes , firefox-26.0-8.fc20.x86_64 fixed the flash plugin , at least in first big test , but if work there means that works .

Comment 3 Sergio Monteiro Basto 2014-01-29 23:28:23 UTC
after some hours of testing I can say this rocks ! , what is the patch that you applied to  
http://pkgs.fedoraproject.org/cgit/firefox.git/log/?h=f20 ?

Comment 4 Jan Horak 2014-01-30 10:28:42 UTC
System cairo library is the culprit here. We use cairo from firefox tarball in in xulrunner and firefox package use system cairo. I'm doing builds of firefox without system cairo now. Thank you for your patience and testing.

Comment 5 Kayvan Sylvan 2014-01-30 19:25:30 UTC
I had the same problem, installed the xhorak-firefox-without-gstreamer repo and "yum update" to firefox-26.0-8.fc20.x86_64 and that fixed my problem too. Thanks!

Comment 6 Fedora Update System 2014-02-04 18:56:26 UTC
xulrunner-27.0-1.fc20,firefox-27.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc20,firefox-27.0-1.fc20

Comment 7 Fedora Update System 2014-02-04 18:56:50 UTC
xulrunner-27.0-1.fc19,firefox-27.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc19,firefox-27.0-1.fc19

Comment 8 Fedora Update System 2014-02-06 03:43:06 UTC
xulrunner-27.0-1.fc20, firefox-27.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-02-12 14:41:41 UTC
xulrunner-27.0-1.fc19, firefox-27.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.