Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058964 - Update yum-utils to match upcoming RHBA
Summary: Update yum-utils to match upcoming RHBA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 1.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: John W. Lamb
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 21:02 UTC by John W. Lamb
Modified: 2014-02-10 13:47 UTC (History)
4 users (show)

Fixed In Version: yum-utils-1.1.30-15.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-10 13:47:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0144 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 1.2 yum-utils bug fix update 2014-02-10 18:44:29 UTC

Description John W. Lamb 2014-01-28 21:02:38 UTC
Description of problem:
A new version of yum-plugin-priorities is being delivered as part of build yum-utils-1.1.30-15.el6_5, in advisory RHBA-2014:16905-05. Installation/diagnostic component yum-validator depends on yum-plugin-priorities, so a new advisory needs to be created to prevent dependency issues.

Comment 2 Ma xiaoqiang 2014-02-07 06:38:56 UTC
1.export the env
sed -ie 's/rhn\.redhat/rhn.errata.stage.redhat/' /etc/sysconfig/rhn/up2date
export CONF_INSTALL_METHOD=rhn
export CONF_RHN_USER=${user}
export CONF_RHN_PASS=${passwd}
2.get the "openshift.sh" for ose1.2
2.configure the repos
#sh openshift.sh actions=validate_preflight,configure_repos
3.yum install openshift-enterprise-yum-validator.noarch
#yum install openshift-enterprise-yum-validator.noarch
Output:
<--snip-->
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : yum-utils-1.1.30-17.el6_5.noarch                                                                                                          1/2 
  Installing : openshift-enterprise-yum-validator-1.2.7.0-1.el6op.noarch                                                                                 2/2 
  Verifying  : yum-utils-1.1.30-17.el6_5.noarch                                                                                                          1/2 
  Verifying  : openshift-enterprise-yum-validator-1.2.7.0-1.el6op.noarch                                                                                 2/2 

Installed:
  openshift-enterprise-yum-validator.noarch 0:1.2.7.0-1.el6op                                                                                                

Dependency Installed:
  yum-utils.noarch 0:1.1.30-17.el6_5

Comment 4 errata-xmlrpc 2014-02-10 13:47:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0144.html


Note You need to log in before you can comment on or make changes to this bug.