Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058936 - /etc/pki/libvirt-spice isn't created during setup
Summary: /etc/pki/libvirt-spice isn't created during setup
Keywords:
Status: CLOSED DUPLICATE of bug 1034634
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Leonid Natapov
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 19:19 UTC by Vagner Farias
Modified: 2014-01-31 13:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 13:09:39 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Vagner Farias 2014-01-28 19:19:17 UTC
Description of problem:
/etc/pki/libvirt-spice is unavailable, at least when deploying a RHEL host using hosted engine setup. Actually I'm unsure if component is ovirt-host-deploy or ovirt-hosted-engine-setup. 

This issue prevent the user to start a VM with Spice configured as protocol.

Version-Release number of selected component (if applicable):
ovirt-host-deploy-1.1.3-1.el6ev.noarch
ovirt-hosted-engine-setup-1.0.0-4.el6ev.noarch

How reproducible:
Unsure. Tested only once.

Steps to Reproduce:
1. On RHEL 6.5, install ovirt-hosted-engine-setup and run hosted-engine --deploy
2. Install engine and configure it (rhevm-setup) on created hosted engine vm 
3. After engine is running, create a VM and choose SPICE protocol for console
4. Start created VM

Actual results:
A message similar to the following is show in events tab:

VM VF-RHEL5.9-test is down. Exit message: internal error process exited while connecting to monitor: ((null):18070): Spice-Warning **: reds.c:3255:reds_init_ssl: Could not load certificates from /etc/pki/libvirt-spice/server-cert.pem
failed to initialize spice server.

Expected results:
VM should start.

Additional info:
After manually creating a symlink in RHEL host, pointing /etc/pki/libvirt-spice to /etc/pki/vdsm/libvirt-spice, VM is able to start.

This issue happened only on the first virtualization node. I added a second node using hosted-engine setup tool and although the certs are available only at /etc/pki/vdsm/libvirt-spice, it's working.

Comment 1 Sandro Bonazzola 2014-01-31 13:09:39 UTC

*** This bug has been marked as a duplicate of bug 1034634 ***


Note You need to log in before you can comment on or make changes to this bug.