Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058857 - Red Hat logo in Plasma panel is poorly resized.
Summary: Red Hat logo in Plasma panel is poorly resized.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-logos
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.0
Assignee: Ngo Than
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 16:21 UTC by Martin
Modified: 2014-09-15 00:04 UTC (History)
5 users (show)

Fixed In Version: redhat-logos-70.0.3-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 10:10:37 UTC


Attachments (Terms of Use)
screenshot (deleted)
2014-01-28 16:21 UTC, Martin
no flags Details
screenshot 2 (deleted)
2014-01-28 17:57 UTC, Martin
no flags Details
screenshot 3 (deleted)
2014-03-05 15:57 UTC, Martin
no flags Details

Description Martin 2014-01-28 16:21:24 UTC
Created attachment 856692 [details]
screenshot

Description of problem:
Red Hat logo in Plasma panel is poorly resized.

Version-Release number of selected component (if applicable):
kde-workspace-4.10.5-9.el7.x86_64

How reproducible:
always

Steps to Reproduce:
Login to KDE

Maybe, you have to adjust panel height. For me it was default size, YMMV.

Actual results:
Shadownman is cropped, see screenshot.

Expected results:
Scale logo properly.

Comment 1 Martin 2014-01-28 17:57:01 UTC
Created attachment 856726 [details]
screenshot 2

whole-screen screenshot from new user account

Comment 2 Vitezslav Humpa 2014-02-13 11:39:37 UTC
Same here, with a fresh user on Snap6.

Comment 3 Jan Grulich 2014-03-03 09:53:56 UTC
This is not a bug in kde-workspace. It seems that fedora-logo-icon.png in size 24x24 is the only one which is trimmed, but I guess it shouldn't be.

Comment 4 Ray Strode [halfline] 2014-03-03 15:28:41 UTC
probably broke when fixing bug 1042818 .  IIRC, during that bug brand sent me a new shadow man SVG file. When generating the individual sizes, i must have messed that one up.

than, I see you're taking this bug over.  Are you just going to regenerate the image from the scalable version? or shrink the 48x48 in half?

Comment 5 Ngo Than 2014-03-03 15:46:22 UTC
Ray, i regenerated SVG file.

Comment 6 Ray Strode [halfline] 2014-03-03 16:00:35 UTC
sounds good.

Comment 7 Ngo Than 2014-03-03 16:16:34 UTC
it's fixed in redhat-logos-70.0.3-4

Comment 9 Martin 2014-03-05 15:57:42 UTC
Created attachment 871044 [details]
screenshot 3

I still see same behavior with redhat-logos-70.0.3-4.el7.noarch

Comment 10 Vitezslav Humpa 2014-03-05 16:49:29 UTC
With a new user, icon now sizes properly (unlike in c#2), using the updated icon.

Comment 11 Ludek Smid 2014-06-13 10:10:37 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.