Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058839 - events are not delivered if using ACLs after 1.1.3.3
Summary: events are not delivered if using ACLs after 1.1.3.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Blake
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1054203
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 15:30 UTC by Cole Robinson
Modified: 2014-02-28 18:31 UTC (History)
11 users (show)

Fixed In Version: libvirt-1.1.3.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-28 18:31:45 UTC


Attachments (Terms of Use)

Description Cole Robinson 2014-01-28 15:30:00 UTC
From https://bugzilla.redhat.com/show_bug.cgi?id=1054203

(In reply to Eric Blake from comment #4)
> Reopening - 1.1.3.3-1 has a regression that if polkit ACLs are enabled, no
> events are delivered, even when the ACLs would permit it.  This is because
> the code for delivering events is in a different thread than the API that
> triggered the event, but we didn't have identity checking set up correctly. 
> I'm working on a fix.

Comment 1 Eric Blake 2014-02-05 13:48:50 UTC
Upstream patch proposed
https://www.redhat.com/archives/libvir-list/2014-January/msg01406.html

Comment 2 Eric Blake 2014-02-05 15:31:30 UTC
Ready for build:

commit fad8d7dff7f800b68a9a716967e63b846daf63b2
Author: Eric Blake <eblake@redhat.com>
Date:   Tue Jan 28 14:50:02 2014 -0700

    event: move event filtering to daemon (regression fix)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1058839

Comment 3 Fedora Update System 2014-02-19 01:00:18 UTC
libvirt-1.1.3.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libvirt-1.1.3.4-1.fc20

Comment 4 Fedora Update System 2014-02-22 00:57:24 UTC
Package libvirt-1.1.3.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.1.3.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2864/libvirt-1.1.3.4-1.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-02-28 18:31:45 UTC
libvirt-1.1.3.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.