Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058819 - [GSS 7.0] Upgrading from HTB to Snapshot 3 yields failed dependencies
Summary: [GSS 7.0] Upgrading from HTB to Snapshot 3 yields failed dependencies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-glamor
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL: http//
Whiteboard:
Depends On:
Blocks: 860099
TreeView+ depends on / blocked
 
Reported: 2014-01-28 15:10 UTC by Andrius Benokraitis
Modified: 2015-07-14 04:27 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-glamor-0.5.1-4.20140115gitfb4d046c.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-04 17:48:42 UTC


Attachments (Terms of Use)

Description Andrius Benokraitis 2014-01-28 15:10:35 UTC
[root@localhost ~]# yum update
Loaded plugins: langpacks, product-id, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
google-chrome                                            |  951 B     00:00    
rhel-7-workstation-htb-rpms                              | 3.4 kB     00:00    
google-chrome/primary                                      | 1.9 kB   00:00    
google-chrome                                                               3/3
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:32.0.1700.77-1 will be updated
---> Package google-chrome-stable.x86_64 0:32.0.1700.102-1 will be an update
---> Package xorg-x11-drv-ati.x86_64 0:7.2.0-6.20131023gitf1dc677.el7 will be updated
---> Package xorg-x11-drv-ati.x86_64 0:7.2.0-8.20140113git3213df1.el7 will be an update
---> Package xorg-x11-drv-dummy.x86_64 0:0.3.6-13.el7 will be updated
---> Package xorg-x11-drv-dummy.x86_64 0:0.3.6-15.el7 will be an update
---> Package xorg-x11-drv-evdev.x86_64 0:2.8.2-3.el7 will be updated
---> Package xorg-x11-drv-evdev.x86_64 0:2.8.2-5.el7 will be an update
---> Package xorg-x11-drv-fbdev.x86_64 0:0.4.3-12.el7 will be updated
---> Package xorg-x11-drv-fbdev.x86_64 0:0.4.3-14.el7 will be an update
---> Package xorg-x11-drv-intel.x86_64 0:2.21.15-9.el7 will be updated
---> Package xorg-x11-drv-intel.x86_64 0:2.21.15-13.el7 will be an update
---> Package xorg-x11-drv-modesetting.x86_64 0:0.8.0-6.el7 will be updated
---> Package xorg-x11-drv-modesetting.x86_64 0:0.8.0-9.el7 will be an update
---> Package xorg-x11-drv-nouveau.x86_64 1:1.0.10-3.el7 will be updated
---> Package xorg-x11-drv-nouveau.x86_64 1:1.0.10-5.el7 will be an update
---> Package xorg-x11-drv-qxl.x86_64 0:0.1.1-5.el7 will be updated
---> Package xorg-x11-drv-qxl.x86_64 0:0.1.1-8.el7 will be an update
---> Package xorg-x11-drv-synaptics.x86_64 0:1.7.1-7.el7 will be updated
---> Package xorg-x11-drv-synaptics.x86_64 0:1.7.1-10.el7 will be an update
---> Package xorg-x11-drv-v4l.x86_64 0:0.2.0-33.el7 will be updated
---> Package xorg-x11-drv-v4l.x86_64 0:0.2.0-35.el7 will be an update
---> Package xorg-x11-drv-vesa.x86_64 0:2.3.2-12.el7 will be updated
---> Package xorg-x11-drv-vesa.x86_64 0:2.3.2-14.el7 will be an update
---> Package xorg-x11-drv-vmmouse.x86_64 0:13.0.0-8.el7 will be updated
---> Package xorg-x11-drv-vmmouse.x86_64 0:13.0.0-10.el7 will be an update
---> Package xorg-x11-drv-vmware.x86_64 0:13.0.1-5.el7 will be updated
---> Package xorg-x11-drv-vmware.x86_64 0:13.0.1-7.el7 will be an update
---> Package xorg-x11-drv-void.x86_64 0:1.4.0-21.el7 will be updated
---> Package xorg-x11-drv-void.x86_64 0:1.4.0-23.el7 will be an update
---> Package xorg-x11-drv-wacom.x86_64 0:0.23.0-3.el7 will be updated
---> Package xorg-x11-drv-wacom.x86_64 0:0.23.0-5.el7 will be an update
---> Package xorg-x11-glamor.x86_64 0:0.5.1-3.20131023git16c86bd.el7 will be updated
---> Package xorg-x11-glamor.x86_64 0:0.5.1-4.20131023git16c86bd.el7 will be an update
--> Processing Dependency: xserver-abi(videodrv-20131101) >= 0 for package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64
--> Processing Dependency: xserver-abi(ansic-20131101) >= 0 for package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64
---> Package xorg-x11-server-Xorg.x86_64 0:1.14.99.901-5.20131101.el7 will be updated
--> Processing Dependency: xserver-abi(ansic-20131101) >= 0 for package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64
--> Processing Dependency: xserver-abi(videodrv-20131101) >= 0 for package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64
---> Package xorg-x11-server-Xorg.x86_64 0:1.15.0-2.el7 will be an update
---> Package xorg-x11-server-common.x86_64 0:1.14.99.901-5.20131101.el7 will be updated
---> Package xorg-x11-server-common.x86_64 0:1.15.0-2.el7 will be an update
--> Finished Dependency Resolution
Error: Package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64 (rhel-7-workstation-htb-rpms)
           Requires: xserver-abi(videodrv-20131101) >= 0
           Removing: xorg-x11-server-Xorg-1.14.99.901-5.20131101.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-20131101) = 0
           Updated By: xorg-x11-server-Xorg-1.15.0-2.el7.x86_64 (rhel-7-workstation-htb-rpms)
              ~xserver-abi(videodrv-15) = 0
           Available: xorg-x11-server-Xorg-1.14.99.901-6.20131101.el7.x86_64 (rhel-7-workstation-htb-rpms)
               xserver-abi(videodrv-20131101) = 0
Error: Package: xorg-x11-glamor-0.5.1-4.20131023git16c86bd.el7.x86_64 (rhel-7-workstation-htb-rpms)
           Requires: xserver-abi(ansic-20131101) >= 0
           Removing: xorg-x11-server-Xorg-1.14.99.901-5.20131101.el7.x86_64 (@anaconda/7.0)
               xserver-abi(ansic-20131101) = 0
           Updated By: xorg-x11-server-Xorg-1.15.0-2.el7.x86_64 (rhel-7-workstation-htb-rpms)
              ~xserver-abi(ansic-0) = 4
           Available: xorg-x11-server-Xorg-1.14.99.901-6.20131101.el7.x86_64 (rhel-7-workstation-htb-rpms)
               xserver-abi(ansic-20131101) = 0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Andrius Benokraitis 2014-01-28 15:16:58 UTC
FYI - I was running the High Touch Beta (day0) and upgraded to Snapshot 3, and it succeeded in upgrading all but these packages.

Comment 2 Daniel Mach 2014-01-28 15:19:25 UTC
Does yum distro-sync work or is it broken too?

Comment 3 Andrius Benokraitis 2014-01-28 15:25:22 UTC
distro-sync yields the same results as Comment #0

Comment 6 Adam Jackson 2014-01-28 23:06:17 UTC
Due to some confusion related to the mass rebuild, an older version of glamor was included in snapshot 3.  I've corrected the error, and a new build should arrive in the next snapshot.


Note You need to log in before you can comment on or make changes to this bug.