Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058731 - OSError: [Errno 2] No such file or directory
Summary: OSError: [Errno 2] No such file or directory
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:7cf3ec6539cd1b04fc480d5120c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 12:53 UTC by Michal Privoznik
Modified: 2014-07-18 19:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 19:14:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: anaconda.log (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: environ (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: lsblk_output (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: nmcli_dev_list (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: os_info (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: program.log (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: storage.log (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: syslog (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: ifcfg.log (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details
File: packaging.log (deleted)
2014-01-28 12:53 UTC, Michal Privoznik
no flags Details

Description Michal Privoznik 2014-01-28 12:53:09 UTC
Version-Release number of selected component:
anaconda-19.31.51-1

The following was filed automatically by anaconda:
anaconda 19.31.51-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
    raise child_exception
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 82, in _run_program
    preexec_fn=chroot, cwd=root, env=env)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 129, in execWithRedirect
    log_output=log_output, binary_output=binary_output)[0]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1331, in execute
    root=ROOT_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 69, in doConfiguration
    ksdata.services.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 2] No such file or directory

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/65714/initrd method=http://download-01.eng.brq.redhat.com/pub/rhel/rel-eng/RHEL-7.0-20140127.0/compose/Server/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/rhel/rel-eng/RHEL-7.0-20140127.0/compose/Server/x86_64/os/  BOOT_IMAGE=/distrotrees/65714/kernel 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-78.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Client release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0

Comment 1 Michal Privoznik 2014-01-28 12:53:14 UTC
Created attachment 856565 [details]
File: anaconda-tb

Comment 2 Michal Privoznik 2014-01-28 12:53:17 UTC
Created attachment 856566 [details]
File: anaconda.log

Comment 3 Michal Privoznik 2014-01-28 12:53:18 UTC
Created attachment 856567 [details]
File: environ

Comment 4 Michal Privoznik 2014-01-28 12:53:21 UTC
Created attachment 856568 [details]
File: lsblk_output

Comment 5 Michal Privoznik 2014-01-28 12:53:23 UTC
Created attachment 856569 [details]
File: nmcli_dev_list

Comment 6 Michal Privoznik 2014-01-28 12:53:25 UTC
Created attachment 856570 [details]
File: os_info

Comment 7 Michal Privoznik 2014-01-28 12:53:27 UTC
Created attachment 856571 [details]
File: program.log

Comment 8 Michal Privoznik 2014-01-28 12:53:31 UTC
Created attachment 856572 [details]
File: storage.log

Comment 9 Michal Privoznik 2014-01-28 12:53:34 UTC
Created attachment 856573 [details]
File: syslog

Comment 10 Michal Privoznik 2014-01-28 12:53:36 UTC
Created attachment 856574 [details]
File: ifcfg.log

Comment 11 Michal Privoznik 2014-01-28 12:53:38 UTC
Created attachment 856575 [details]
File: packaging.log

Comment 13 Samantha N. Bueno 2014-02-04 04:25:43 UTC
Please provide steps to reproduce this.

Comment 14 Michal Privoznik 2014-02-04 10:30:13 UTC
(In reply to Samantha N. Bueno from comment #13)
> Please provide steps to reproduce this.

1. Create a new VM under virt-manager: Select PXE install, Chose RHEL-7 as guest OS, leave default RAM (1024MB) and CPU (1), Create a disk image on the computer's HDD, and customize configuration before install (make sure to create macvtap device over eth0)

2. Choose Latest RHEL and Fedora in globalsync, and then select RHEL-7.0-20140130-Server

3. In anaconda, add time.englab.brq.redhat.com to NTP server pool, set Europe/Prague TZ, Choose custom partitioning and make just one partition / for everything (no LVM, no separate partitions for /boot or something, no swap either). Select 'Minimal install'. and start instalation.

4. Enter root password and create a user.

5. After the installation is finisher, click the 'configure' button in the right lower corner.

6. Observe error.

Comment 15 Chris Lumens 2014-02-04 19:14:08 UTC
anaconda is getting OOM killed:

12:50:26,113 ERR kernel:[ 5494.154327] Out of memory: Kill process 1199 (anaconda) score 100 or sacrifice child
12:50:26,113 ERR kernel:[ 5494.154335] Killed process 1552 (anaconda-yum) total-vm:299044kB, anon-rss:59092kB, file-rss:1300kB

Also note in your syslog that polkitd is taking up 129 MB of memory.  That seems excessive.  For now you should be able to work around it by adding more memory to your VM.

Comment 16 David Cantrell 2014-07-18 19:14:45 UTC
Nothing here seems to be an anaconda issue that can be resolved.  We are unable to reliably reproduce this problem and have not had it come up since winter.  NAK'ing for now and setting as CANTFIX since it's not really clear what the problem is (if there is a problem).


Note You need to log in before you can comment on or make changes to this bug.