Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058627 - [Intel 7.0 Bug] migration failed, unsupported configuration: Unable to find security driver for label selinux
Summary: [Intel 7.0 Bug] migration failed, unsupported configuration: Unable to find s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Denemark
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 08:11 UTC by chao.zhou
Modified: 2014-03-04 09:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-04 09:38:12 UTC


Attachments (Terms of Use)
xml config (deleted)
2014-01-28 08:11 UTC, chao.zhou
no flags Details

Description chao.zhou 2014-01-28 08:11:47 UTC
Created attachment 856421 [details]
xml config

Description of problem:
Live migration a guest to a remote host, will report "unsupported configuration: Unable to find security driver for label selinux"
On RHEL7 beta version, we didn't meet this issue.

Version-Release number of selected component (if applicable):

kernel-3.10.0-71.el7.x86_64
qemu-kvm-1.5.3-37.el7.x86_64
libvirt-1.1.1-18.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1.Disable selinux in host
2.create a guest without selinux label
3.doing migration using "virsh migrate --live rhel7_guest qemu+ssh://$IP/system"

Actual results:

error: unsupported configuration: Unable to find security driver for label selinux

Expected results:

migration success.

Additional info:

Comment 2 Jiri Denemark 2014-01-31 10:34:18 UTC
I tried playing with this and the only way I was able to get this error is when I was migrating from a host with SELinux enabled to a host with SELinux disabled. Are you sure both hosts have SELinux disabled? Can you provide the output of virsh dumpxml rhel7_guest before you migrate it? And capturing libvirtd debug logs (http://wiki.libvirt.org/page/DebugLogs) generated during the migration attempt by both source and destination logs would be useful too.

BTW, the attached XML is not describing a domain with no security label. It is a domain with default security label, that is the result depends on what security drivers are available on the host.

Comment 3 chao.zhou 2014-02-12 09:25:24 UTC
We have tried this on SP4 with
libvirt-1.1.1-19.el7.x86_64
kernel-3.10.0-78.el7.x86_64
qemu-kvm-1.5.3-41.el7.x86_64

the migration can be successful.

The above issue is caused by different version of host, it will happen when migrate from sp4 to beta even if SELinux is disabled in both hosts.

Comment 4 Jiri Denemark 2014-03-04 09:38:12 UTC
OK so if there was a bug it was apparently fixed already.


Note You need to log in before you can comment on or make changes to this bug.