Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058532 - Pitivi dependency missing [NEEDINFO]
Summary: Pitivi dependency missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pitivi
Version: 20
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 01:24 UTC by Stephen Haffly
Modified: 2014-01-28 19:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-28 03:24:30 UTC
znmeb: needinfo? (extras-qa)


Attachments (Terms of Use)

Description Stephen Haffly 2014-01-28 01:24:34 UTC
Description of problem:
Attempting to update Fedora 20 x86_64 which has pitivi installed. Dependency resolution fails, stating that the proper version of gnonlin is not installed and not available.

Version-Release number of selected component (if applicable):
pitivi-0.92-1.fc20.x86_64 (updates)

Requires: gnonlin >= 1.1.90
Installed: gnonlin-0.10.17-5.fc20.x86_64 (installed)

How reproducible:
Execute "yum update"

Steps to Reproduce:
1. execute yum update
2. Package resolution fails
3. repetition yields same result

Actual results:
dependency resolution fails

Expected results:
pitivi should install as gnonlin is already at the latest available version.

Additional info:
yum update pitivi
Loaded plugins: langpacks, priorities, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package pitivi.noarch 0:0.15.2-4.fc20 will be updated
---> Package pitivi.x86_64 0:0.92-1.fc20 will be an update
--> Processing Dependency: python-gstreamer1 >= 1.1.90 for package: pitivi-0.92-1.fc20.x86_64
--> Processing Dependency: gst-editing-services >= 1.1.90 for package: pitivi-0.92-1.fc20.x86_64
--> Processing Dependency: gnonlin >= 1.1.90 for package: pitivi-0.92-1.fc20.x86_64
--> Processing Dependency: pycanberra for package: pitivi-0.92-1.fc20.x86_64
--> Running transaction check
---> Package gst-editing-services.x86_64 0:1.1.90-5.fc20.20140123git105d901 will be installed
---> Package pitivi.x86_64 0:0.92-1.fc20 will be an update
--> Processing Dependency: gnonlin >= 1.1.90 for package: pitivi-0.92-1.fc20.x86_64
---> Package pycanberra.noarch 0:0-0.4.git65c3b3f.fc20 will be installed
---> Package python-gstreamer1.x86_64 0:1.1.90-1.fc20 will be installed
--> Finished Dependency Resolution
Error: Package: pitivi-0.92-1.fc20.x86_64 (updates)
           Requires: gnonlin >= 1.1.90
           Installed: gnonlin-0.10.17-5.fc20.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


If gst-editing-services is now what is used by pitivi instead of gnonlin, was it just an error that made the dependency for gnonlin to be the  same as the version of gst-editing-services?

Comment 1 M. Edward (Ed) Borasky 2014-01-28 02:42:37 UTC
Sigh ... this breaks my ISO creation script. Is there a workaround?

Comment 2 Stephen Haffly 2014-01-28 03:24:30 UTC
Okay, I see now that there is an update to gnonlin in updates-testing. 
gnonlin-1.1.90-1.fc20.x86_64

yum --enablerepo=updates-testing update gnonlin

After getting the updated gnonlin, pitivi updates fine.

The gnonlin file will probably show up in the regular updates repo shortly. Since it looks like this was just an issue of one file being delayed, and not a bug, I am going to mark this bug as closed.

Comment 3 M. Edward (Ed) Borasky 2014-01-28 19:06:07 UTC
(In reply to Stephen Haffly from comment #2)
> Okay, I see now that there is an update to gnonlin in updates-testing. 
> gnonlin-1.1.90-1.fc20.x86_64
> 
> yum --enablerepo=updates-testing update gnonlin
> 
> After getting the updated gnonlin, pitivi updates fine.
> 
> The gnonlin file will probably show up in the regular updates repo shortly.
> Since it looks like this was just an issue of one file being delayed, and
> not a bug, I am going to mark this bug as closed.

This may not be a bug in pitivi but this is not the first time 'yum update' has had propose updates with missing dependencies on my systems. Something is broken in the process that delivers packages to the repositories, or there's a race condition somewhere in yum's dependency solver.

This isn't a great hassle for my systems; I just wait a few days and the dependency shows up, or I do what you did and enable the updates-testing repo. But I build a Fedora remix and this breaks the script that creates ISO files. So I'm interested in having someone at Fedora figure out what sort of timing glitch causes missing dependencies in the 'updates' repo.

So I'm going to tack on a 'needinfo' to QA

1. What's the process by which packages enter the 'updates' repo?
2. Is presence of their dependencies in 'updates' checked before they are admitted?


Note You need to log in before you can comment on or make changes to this bug.