Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058511 - Cannot modify logical network on Admin Portal if has VMs assigned to it
Summary: Cannot modify logical network on Admin Portal if has VMs assigned to it
Keywords:
Status: CLOSED DUPLICATE of bug 1029084
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: nobody nobody
QA Contact: Pavel Stehlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 23:39 UTC by Marina
Modified: 2018-12-04 17:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-28 15:48:23 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 714203 None None None Never

Description Marina 2014-01-27 23:39:45 UTC
REHV Web Admin Portal does not allow to modify logical network (for instance, adding vlan tag to it), if this network has VMs assigned to it.
This is wrong.
It is impossible to remove nics from all the running and preconfigured VMs on that network, in order to allow its edit. The user should be able to modify the network regardless of the VMs attached to it.

Scenario from my case:
Customer wants to use eth0 for more the one subnet. This requires VLAN tagging on all the subnets attached to this interface.
Customer has already setup his environment having rhevm logical network on eth0, without VLAN tag on it. He also has many VMs running and using this rhevm logical network. 
He needs to edit rhevm logical network to have a VLAN tag, but Web Admin Portal does not let him do it.

There is no way to scale up his environment at this point.

Comment 1 Marina 2014-01-28 15:48:23 UTC

*** This bug has been marked as a duplicate of bug 1029084 ***


Note You need to log in before you can comment on or make changes to this bug.