Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058427 - Add bcfg2 package to EPEL7
Summary: Add bcfg2 package to EPEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bcfg2
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: John Morris
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1060798 1060799 1060800
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 18:50 UTC by Sol Jerome
Modified: 2014-03-17 05:59 UTC (History)
2 users (show)

Fixed In Version: bcfg2-1.3.3-5.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-09 04:36:08 UTC


Attachments (Terms of Use)

Description Sol Jerome 2014-01-27 18:50:14 UTC
Description of problem:

The bcfg2 package is currently not built in epel7 beta.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I have patched the EPEL spec file to include fixes from upstream which should make it RHEL7-compatible. The branch with changes can be found at https://github.com/solj/bcfg2-spec/tree/upstream-specfile-fixes.

Comment 1 John Morris 2014-01-27 20:53:00 UTC
Hi, Sol!

I haven't been tracking epel7 beta progress so far.  There was an email on the 10th to devel-announce@lists.fedoraproject.org saying epel7 is open, and pointing to this FAQ:

https://fedoraproject.org/wiki/EPEL/epel7/Requests#EPEL_Branch_Requests

And this location for requests:

https://fedoraproject.org/wiki/EPEL/epel7/Requests

I put the bcfg2 branch request in the table, and it mysteriously vanished; the history says it was undone by 'limb', the package branch maintainer, so hopefully something is being done with it.

Thanks for the updates.

Comment 2 Sol Jerome 2014-01-30 13:58:17 UTC
(In reply to John Morris from comment #1)
> Hi, Sol!
> 
> I haven't been tracking epel7 beta progress so far.  There was an email on
> the 10th to devel-announce@lists.fedoraproject.org saying epel7 is open, and
> pointing to this FAQ:
> 
> https://fedoraproject.org/wiki/EPEL/epel7/Requests#EPEL_Branch_Requests
> 
> And this location for requests:
> 
> https://fedoraproject.org/wiki/EPEL/epel7/Requests
> 

Yeah, I had looked at this as well. I'm not sure what exactly the process is for adding requests.

> I put the bcfg2 branch request in the table, and it mysteriously vanished;
> the history says it was undone by 'limb', the package branch maintainer, so
> hopefully something is being done with it.
> 

I still think you'll need the changes from my git branch in order to get the package to build properly for EPEL7 (I did).

> Thanks for the updates.

No problem. Thanks for finally merging these spec files :-).

Comment 3 Fabian Affolter 2014-01-30 14:21:56 UTC
(In reply to John Morris from comment #1)
> I put the bcfg2 branch request in the table, and it mysteriously vanished;
> the history says it was undone by 'limb', the package branch maintainer, so
> hopefully something is being done with it.

The epel7 branch seems to be ready now.

Comment 4 John Morris 2014-01-30 15:09:43 UTC
Ah, epel7 branch is ready, thanks for the heads up.

Sol, if I'm understanding well, your commit [1] will introduce a regression on EL5 with the BR: Django >= 1.2.  See the bz at [2].

Your %changelog entry says "Add Django dependency for bcfg2-web (the web package *does* require Django for the database)".

Should we then disable bcfg2-web for EL5?  That removes the possibility of 'bring your own Django >= 1.2' that I mentioned in [3], but that's ok with me.



[1] https://github.com/solj/bcfg2-spec/commit/6c59b3bec5c788bec30fefc1e417f60c79da3bac#diff-e0e00f627936de04fb52f1bc92035a28R299

[2] https://bugzilla.redhat.com/show_bug.cgi?id=1043229

[3] http://article.gmane.org/gmane.comp.sysutils.bcfg2.devel/4714

Comment 5 Sol Jerome 2014-01-30 15:28:23 UTC
Yeah, I saw that bug previously. The problem is that bcfg2-web won't work at all without Django (or Django-south). Is there any way to leave the dependency there a la Django-south?

http://pkgs.fedoraproject.org/cgit/Django-south.git/tree/Django-south.spec?h=el5#n16

Even though the Django package doesn't exist in RHEL5 (as far as I can tell), it seems like Django-south still requires it.

(In reply to John Morris from comment #4)
> Ah, epel7 branch is ready, thanks for the heads up.
> 
> Sol, if I'm understanding well, your commit [1] will introduce a regression
> on EL5 with the BR: Django >= 1.2.  See the bz at [2].
> 
> Your %changelog entry says "Add Django dependency for bcfg2-web (the web
> package *does* require Django for the database)".
> 
> Should we then disable bcfg2-web for EL5?  That removes the possibility of
> 'bring your own Django >= 1.2' that I mentioned in [3], but that's ok with
> me.
> 
> 
> 
> [1]
> https://github.com/solj/bcfg2-spec/commit/
> 6c59b3bec5c788bec30fefc1e417f60c79da3bac#diff-
> e0e00f627936de04fb52f1bc92035a28R299
> 
> [2] https://bugzilla.redhat.com/show_bug.cgi?id=1043229
> 
> [3] http://article.gmane.org/gmane.comp.sysutils.bcfg2.devel/4714

Comment 6 John Morris 2014-01-30 19:50:07 UTC
Agh, forgot about the completely missing Django pkg; the 1.2 version dep is a red herring.

As I remember from looking at the Django pkg's git tree, Django *was* in el5 at one time, but now is not.  I'm sure the Django-south maintainer is getting nagging email from Fedora buildsys about the broken dep.

I still don't see any other way around disabling the bcfg2-web subpkg build on EL5.  The server and client packages should continue working, but as it is today, there's no way to get the bcfg2-web package to work only using EL5 and EPEL5 deps (other than updating the Django pkg, of course).

The bcfg2-web package *could* be disabled with a macro so that anyone who 'brings their own' Django package may easily re-enable and rebuild the package.

Comment 7 Sol Jerome 2014-01-30 20:05:16 UTC
John,

That works for me then. If you could also give me a pull request upstream with that macro, that'd be great!

Thanks!

Comment 8 John Morris 2014-02-02 06:30:35 UTC
Hi Sol,

Just merged your changes and disabled the bcfg2-web build for EL5 [1].  Thanks for the fixes.

The EPEL7 distribution seems not yet to include the pylibacl, pylint, python-pep8 packages.  These might only be needed for the unit tests, so those BuildRequirements and the %check section are disabled for EL7 [2].  Those packages will need bugs filed against them (as blocking this ticket) requesting EPEL7 builds.  How did you get your packages to build without those?

The scratch build [3] is still failing because the %{_unitdir} macro is apparently absent for EL7.  Gack!  I couldn't quickly determine the fix, and that's all I've got for tonight....

[1] https://github.com/zultron/bcfg2-rpm/commit/870d2e24ada7873d07ab0ecaffa41edb2112fa77

[2] https://github.com/zultron/bcfg2-rpm/commit/d2b7abbe082036621fe59478e50d5e58b89500d7

[3] http://koji.fedoraproject.org/koji/taskinfo?taskID=6480536

Comment 9 Sol Jerome 2014-02-03 15:10:33 UTC
(In reply to John Morris from comment #8)
> Hi Sol,
> 
> Just merged your changes and disabled the bcfg2-web build for EL5 [1]. 
> Thanks for the fixes.
> 

Awesome. Thanks!

> The EPEL7 distribution seems not yet to include the pylibacl, pylint,
> python-pep8 packages.  These might only be needed for the unit tests, so
> those BuildRequirements and the %check section are disabled for EL7 [2]. 
> Those packages will need bugs filed against them (as blocking this ticket)
> requesting EPEL7 builds.  How did you get your packages to build without
> those?
> 

I didn't. I forward ported them from EPEL6 which was fairly trivial.

> The scratch build [3] is still failing because the %{_unitdir} macro is
> apparently absent for EL7.  Gack!  I couldn't quickly determine the fix, and
> that's all I've got for tonight....
> 

Odd. I didn't receive any failures once I got all the dependencies in place.

> [1]
> https://github.com/zultron/bcfg2-rpm/commit/
> 870d2e24ada7873d07ab0ecaffa41edb2112fa77
> 
> [2]
> https://github.com/zultron/bcfg2-rpm/commit/
> d2b7abbe082036621fe59478e50d5e58b89500d7
> 
> [3] http://koji.fedoraproject.org/koji/taskinfo?taskID=6480536

Comment 10 John Morris 2014-02-03 16:51:50 UTC
(In reply to Sol Jerome from comment #9)
> (In reply to John Morris from comment #8)
> 
> > The EPEL7 distribution seems not yet to include the pylibacl, pylint,
> > python-pep8 packages.  These might only be needed for the unit tests, so
> > those BuildRequirements and the %check section are disabled for EL7 [2]. 
> > Those packages will need bugs filed against them (as blocking this ticket)
> > requesting EPEL7 builds.  How did you get your packages to build without
> > those?
> > 
> 
> I didn't. I forward ported them from EPEL6 which was fairly trivial.

Ok.  I filed bugs against those packages requesting EPEL7 builds.

> > The scratch build [3] is still failing because the %{_unitdir} macro is
> > apparently absent for EL7.  Gack!  I couldn't quickly determine the fix, and
> > that's all I've got for tonight....
> > 
> 
> Odd. I didn't receive any failures once I got all the dependencies in place.

Check out my scratch build [4] logs.  The build fails with the error message "File must begin with "/": %{_unitdir}/bcfg2.service"; I believe this means that "%{_unitdir}" is being treated literally as part of the file name, and it's going unexpanded presumably because it isn't defined.

IIRC EL7 is based on FC19, which builds just fine [5], so I'm confused.  Another package, apcupsd, doesn't use a macro [6].  Fedora packaging guidelines for systemd [7] says "Packages with systemd unit files *must* put them into %{_unitdir}."

I'll ask for clarification on the fedora-devel list.


[4] http://koji.fedoraproject.org/koji/taskinfo?taskID=6485759
[5] http://koji.fedoraproject.org/koji/taskinfo?taskID=6485815
[6] http://pkgs.fedoraproject.org/cgit/apcupsd.git/tree/apcupsd.spec?h=epel7#n146
[7] http://fedoraproject.org/wiki/Packaging:Systemd#Filesystem_locations

Comment 11 John Morris 2014-02-03 17:00:58 UTC
Erm, rereading [7], it's spelled out right there:  just add a BR: systemd.

Scratch build succeeded.  I'll commit these changes and start the Bodhi process.

Thanks for the help!

Comment 12 Sol Jerome 2014-02-03 17:03:22 UTC
(In reply to John Morris from comment #11)
> Erm, rereading [7], it's spelled out right there:  just add a BR: systemd.
> 
> Scratch build succeeded.  I'll commit these changes and start the Bodhi
> process.
> 
> Thanks for the help!

No, thank you!

Comment 13 John Morris 2014-02-03 17:35:04 UTC
(In reply to Sol Jerome from comment #7)
> That works for me then. If you could also give me a pull request upstream
> with that macro, that'd be great!

Did you want that against your bcfg2 repo [8] or the bcfg2-spec repo [9]?


[8] https://github.com/solj/bcfg2
[9] https://github.com/solj/bcfg2-spec/tree/upstream-specfile-fixes

Comment 14 Sol Jerome 2014-02-03 17:42:10 UTC
Just the main one works.

https://github.com/Bcfg2/bcfg2

Thanks again!

Comment 15 Fedora Update System 2014-02-03 19:16:15 UTC
bcfg2-1.3.3-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-4.el6

Comment 16 Fedora Update System 2014-02-03 19:16:24 UTC
bcfg2-1.3.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-4.fc19

Comment 17 Fedora Update System 2014-02-03 19:16:32 UTC
bcfg2-1.3.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-4.fc20

Comment 18 Fedora Update System 2014-02-03 19:16:46 UTC
bcfg2-1.3.3-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-4.el5

Comment 19 Fedora Update System 2014-02-15 07:04:47 UTC
bcfg2-1.3.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2014-02-15 07:06:17 UTC
bcfg2-1.3.3-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2014-02-20 07:01:15 UTC
bcfg2-1.3.3-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-02-20 07:02:25 UTC
bcfg2-1.3.3-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2014-02-27 17:24:26 UTC
bcfg2-1.3.3-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-5.el5

Comment 24 Fedora Update System 2014-02-27 17:24:44 UTC
bcfg2-1.3.3-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-5.fc20

Comment 25 Fedora Update System 2014-02-27 17:24:54 UTC
bcfg2-1.3.3-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-5.fc19

Comment 26 Fedora Update System 2014-02-27 17:25:02 UTC
bcfg2-1.3.3-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/bcfg2-1.3.3-5.el6

Comment 27 Fedora Update System 2014-02-28 18:38:17 UTC
Package bcfg2-1.3.3-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bcfg2-1.3.3-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3225/bcfg2-1.3.3-5.fc19
then log in and leave karma (feedback).

Comment 28 Fedora Update System 2014-03-09 04:36:08 UTC
bcfg2-1.3.3-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2014-03-09 04:44:19 UTC
bcfg2-1.3.3-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2014-03-17 05:57:38 UTC
bcfg2-1.3.3-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2014-03-17 05:59:33 UTC
bcfg2-1.3.3-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.