Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 105838 - krb5 bad source code
Summary: krb5 bad source code
Keywords:
Status: CLOSED DUPLICATE of bug 82186
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 11:11 UTC by d.binderman
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:49 UTC


Attachments (Terms of Use)

Description d.binderman 2003-09-28 11:11:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package krb5-1.2.7-10 from Redhat 9.0
with compiler flag -Wall.

The compiler said

client.c:220: warning: too few arguments for format

The source code is
               fprintf(stderr, "RPC_TEST_ECHO call %d response wrong: "
                       "arg = %s, resp = %s\n", echo_arg, *echo_resp);

Surely wrong ? Three % specifiers, but only two parameters ?

Also, the compiler said

client.c:326: warning: too few arguments for format

The source code is

                    fprintf(stderr,
                            "RPC_TEST_LENGTHS call %d response wrong\n");

This looks wrong to me. One %d, no number.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with -Wall.
2.
3.
    

Additional info

Comment 1 Marcin Garski 2004-12-18 20:01:23 UTC

*** This bug has been marked as a duplicate of 82186 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.