Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058379 - [RFE] update to current augeas or current lenses
Summary: [RFE] update to current augeas or current lenses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: augeas
Version: 7.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1181710 1197834
TreeView+ depends on / blocked
 
Reported: 2014-01-27 16:58 UTC by Pat Riehecky
Modified: 2015-11-19 10:18 UTC (History)
7 users (show)

Fixed In Version: augeas-1.4.0-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: Augeas 1.4.0 Highlights, important fixes, or notable enhancements: New features: - New aug_cp API, cp/copy command in augtool - New aug_escape_name API - New "errors" command in augtool to print any errors New lenses to parse additional file types: - AFS_Cellalias, parse the OpenAFS CellAlias file - Clamav, parse ClamAV config files - CPanel, parse cpanel.config files - Dns_Zone, parse BIND style DNS zones - Gshadow, parse group shadow file - Iscsid, parse iscsid config file - Known_Hosts, parse SSH known hosts file - Koji, parse Koji config files - Mailscanner, Mailscanner_Rules: parse MailScanner configs - Pagekite, parse Pagekite configs - Pgbouncer, parse pgbouncer connection pooler config - Postfix_sasl_smtpd, parse Postfix SASL config - Puppetfile, parse librarian-puppet's files - Pylonspaste, parse Plon's paste init configs - Sysconfig_routes, parse /etc/sysconfig/network-scripts/route-* - Tuned, parse tuned config files - UpdateDB, parse updatedb.conf, not used by default - Xymon_Alerting, parsing Xymon alerting configs Important notes: This update tries to maintain compatibility with previous versions of Augeas shipped in RHEL 7. Some changes have been made to lenses from Augeas 1.4.0 to ensure better compatibility with applications written against 1.1.0: - Dnsmasq: address/server options are stored as one value, not split - Dovecot: quotes are stored within node values - Jaas: semicolons are stored in the last value, line breaks not supported - Syslog: UDP hosts do not have a "protocol" node, only TCP hosts - UpdateDB: does not load updatedb.conf by default, Simplevars is still used Where incompatibility between 1.1.0 and 1.4.0 was greater, the original 1.1.0 lenses remain the default, and new 1.4.0 lenses are shipped alongside. Users or developers can load these explicitly to gain new features or fixes. Users of augtool can run "augtool -A -t 'Sshd_140 incl /etc/ssh/sshd_config'" for example, to load sshd_config with the new Sshd_140 lens. API users can call aug_transform. - Dhcpd: remains unchanged, new Dhcpd_140 lens is provided - Slapd: remains unchanged, new Slapd_140 lens is provided - Sshd: remains unchanged, new Sshd_140 lens is provided
Clone Of:
Environment:
Last Closed: 2015-11-19 10:18:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2153 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-11-19 09:54:36 UTC

Description Pat Riehecky 2014-01-27 16:58:09 UTC
Description of problem: Augeas 1.2 includes a bunch of updated lenses, many of which fix bugs with config parsing.


Version-Release number of selected component (if applicable):augeas-1.1.0-3.el7


How reproducible:100%


Steps to Reproduce:
1.Review changelog and fixes list from augeas project
2.note how may fixes are listed

For example:
automounter can now support hostnames with '-' in them
dovecot has a bunch of fixes
/etc/exports can now support IPv6 addresses
php can now use php-fpm syntax
postfix now supports '+' in email addresses
/etc/firewalld/firewalld.conf is now parsed
sshd support Ciphers and KezAlgorithms groups
sudoers supports '_' and 'A-Z' in usernames

Additional info:
https://github.com/hercules-team/augeas/blob/master/NEWS

Comment 1 Dominic Cleal 2014-01-27 17:04:48 UTC
Please note that we can usually deal with specific bug fixes faster than RFEs for rebases of a package, so I'd encourage you or any other users/customers with issues in Augeas to also submit them directly via Red Hat Support or Bugzilla.

Comment 7 Pat Riehecky 2015-06-16 13:29:55 UTC
Preview package worked as expected with my existing puppet code.

Comment 8 Xianghua Chen 2015-10-12 05:42:03 UTC
Verified with the package:
augeas-1.4.0-2.el7.x86_64

Verify steps:
Check the following features:
- New aug_cp API, cp/copy command in augtool
- New aug_escape_name API
- New "errors" command in augtool to print any errors

Parse the following file types:
- AFS_Cellalias, parse the OpenAFS CellAlias file
- Clamav, parse ClamAV config files
- CPanel, parse cpanel.config files
- Dns_Zone, parse BIND style DNS zones
- Gshadow, parse group shadow file
- Iscsid, parse iscsid config file
- Known_Hosts, parse SSH known hosts file
- Koji, parse Koji config files
- Mailscanner, Mailscanner_Rules: parse MailScanner configs
- Pagekite, parse Pagekite configs
- Pgbouncer, parse pgbouncer connection pooler config
- Postfix_sasl_smtpd, parse Postfix SASL config
- Puppetfile, parse librarian-puppet's files
- Pylonspaste, parse Plon's paste init configs
- Sysconfig_routes, parse /etc/sysconfig/network-scripts/route-*
- Tuned, parse tuned config files
- UpdateDB, parse updatedb.conf, not used by default
- Xymon_Alerting, parsing Xymon alerting configs


The test result: Verified.

Comment 10 errata-xmlrpc 2015-11-19 10:18:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2153.html


Note You need to log in before you can comment on or make changes to this bug.