Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058368 - rhsmd handles server errors poorly (via ABRT)
Summary: rhsmd handles server errors poorly (via ABRT)
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.1
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel71
TreeView+ depends on / blocked
 
Reported: 2014-01-27 16:27 UTC by Adrian Likins
Modified: 2014-11-17 16:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-17 16:25:19 UTC


Attachments (Terms of Use)

Description Adrian Likins 2014-01-27 16:27:40 UTC
Description of problem:

via uReport from: 

http://faf-report.itos.redhat.com/reports/1016/
http://faf-report.itos.redhat.com/problems/853/

Looks like anything that raises a RemoteServerException (404 etc) causes
rhsmd to fail in check status. 

Hard to tell what causes the RemoteServerException in this case, but something
should be handling that error.


Version-Release number of selected component (if applicable):
subscription-manager-0:1.10.10-1.el7

Comment 2 Bryan Kearney 2014-03-19 20:51:23 UTC
Moving bugs from 7.0 to 7.1

Comment 4 Bryan Kearney 2014-07-30 19:22:06 UTC
Acking 7.1

Comment 5 Devan Goodwin 2014-11-17 16:25:19 UTC

*** This bug has been marked as a duplicate of bug 1113741 ***


Note You need to log in before you can comment on or make changes to this bug.