Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058338 - session-migration: Deadlines do not work.
Summary: session-migration: Deadlines do not work.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Core
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ER1
: 6.0.1
Assignee: Maciej Swiderski
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 15:22 UTC by Marek Baluch
Modified: 2014-08-06 20:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:04:02 UTC
Type: Bug


Attachments (Terms of Use)
stacktrace (deleted)
2014-01-27 15:22 UTC, Marek Baluch
no flags Details

Description Marek Baluch 2014-01-27 15:22:09 UTC
Created attachment 856114 [details]
stacktrace

Description of problem:
If a task which defines a deadline (e.g. with reassignment) is stored in jBPM5 then it's execution will fail in jBPM6.

Based on the error message (whole log attached) it looks like the transaction will not be awaken right away but only if the task in question is accessed. This will fail with message:

XAER_RMFAIL: The command cannot be executed when global transaction is in the  ACTIVE state

Steps to Reproduce:
Using the tests located in: 
http://git.app.eng.bos.redhat.com/jbossqe/brms.git/tree/test-jbpm-session-
migration.
1) Run the from53x UserTaskTest.humanTaskReassignTest()
2) Run the to6x UserTaskTest.humanTaskReassignTest()

Additional info:
Do not use PostgreSQL as there's another issue which hides this one. See BZ-1058301. I used MySQL55.

Comment 1 Maciej Swiderski 2014-01-29 15:02:04 UTC
fixed by using backward compatible discriminator value for EmailNotification entity.

jbpm
master:
https://github.com/droolsjbpm/jbpm/commit/3a5ae9820d158732017c4979cee394c3c7bb439e

6.0.x:
https://github.com/droolsjbpm/jbpm/commit/b85e870dc8a2100f78c4f04c04a7d4c9180299c1

P.S.
same as noted in the other session migration bz, to activate deadlines handling Taskervice needs to be created at least once otherwise deadlines are not loaded from db

Comment 2 Marek Baluch 2014-02-20 08:21:03 UTC
VERIFIED on 6.0.1.ER1


Note You need to log in before you can comment on or make changes to this bug.