Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058312 - da-gui segfaults on inaccessible display
Summary: da-gui segfaults on inaccessible display
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: devassistant
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1042812
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 13:57 UTC by Tomáš Bžatek
Modified: 2015-03-03 23:07 UTC (History)
4 users (show)

Fixed In Version: devassistant-0.9.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 07:31:56 UTC


Attachments (Terms of Use)
terminal snippet (deleted)
2014-01-27 13:57 UTC, Tomáš Bžatek
no flags Details
gdb traceback (deleted)
2014-01-27 13:58 UTC, Tomáš Bžatek
no flags Details
gdb traceback in GtkFileChooser (deleted)
2014-01-27 14:20 UTC, Tomáš Bžatek
no flags Details

Description Tomáš Bžatek 2014-01-27 13:57:18 UTC
Created attachment 856075 [details]
terminal snippet

Description of problem:
da-gui segfaults when $DISPLAY is unset (or probably inaccessible some other way).

Version-Release number of selected component (if applicable):
devassistant-0.8.0-1.fc21.noarch

Steps to Reproduce:
1. unset $DISPLAY
2. da-gui

Actual results:
da-gui[1105]: segfault at 10 ip 00007ff793392145 sp 00007fffbc1dd210 error 4 in libpython2.7.so.1.0[7ff7932d0000+178000]

Additional info:
If gtk_init() is used, it terminates the process on failure. If gtk_init_check() is used, it's a caller responsibility to act accordingly.

Comment 1 Tomáš Bžatek 2014-01-27 13:58:13 UTC
Created attachment 856076 [details]
gdb traceback

Comment 2 Tomáš Bžatek 2014-01-27 14:20:58 UTC
Created attachment 856091 [details]
gdb traceback in GtkFileChooser

Same problem elsewhere, looks like a pygobject bug in handling messages logged through g_log()

Steps to repro:
1. run da-gui, start a new project
2. click the Browse button
3. in GtkFileChooser, navigate to /tmp and click the "Create folder" button
4. da-gui[1497]: segfault at 10 ip 00007f4ede6e7145 sp 00007fffe8ba3160 error 4 in libpython2.7.so.1.0[7f4ede625000+178000]

Comment 3 Petr Hracek 2014-07-28 07:31:56 UTC
This bux is fixed by commit (https://github.com/bkabrda/devassistant/commit/e9e49d08f12088b8a87adfae2785126fce7a44ae)
It is fixed in version devassistant-0.9.1


Note You need to log in before you can comment on or make changes to this bug.