Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058225 - [WHQL][netkvm]Job named PM_PowerStateTransition failed because error pop up while test app's running on win8/win8.1
Summary: [WHQL][netkvm]Job named PM_PowerStateTransition failed because error pop up w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On: 1184818
Blocks: 1191961
TreeView+ depends on / blocked
 
Reported: 2014-01-27 09:33 UTC by Min Deng
Modified: 2015-11-24 08:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
: 1191961 (view as bug list)
Environment:
Last Closed: 2015-11-24 08:39:54 UTC


Attachments (Terms of Use)
Screenshot (deleted)
2014-01-27 09:33 UTC, Min Deng
no flags Details
win81-64 (deleted)
2014-10-17 09:44 UTC, Min Deng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Min Deng 2014-01-27 09:33:00 UTC
Created attachment 855977 [details]
Screenshot

Description of problem:
Job named PM_PowerStateTransition failed because error popo up while test app's running
Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-30.el7.x86_64
kernel-3.10.0-64.el7.x86_64
seabios-1.7.2.2-7.el7.x86_64
virtio-win-prewhql-1.6.7-2

How reproducible:
5 times

Steps to Reproduce:
1.boot up guest with 
Guest 1:
  /usr/libexec/qemu-kvm -m 6G -M pc -smp 4,cores=4 -cpu Penryn -usb -device usb-tablet -drive file=win8-64-new-1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 2e6c9b6a-898c-409f-8c57-27b4f8ae5ef5 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win864-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -spice port=5932,disable-ticketing -vga qxl -global qxl-vga.revision=3 -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win8-64-netkvm-1.6.7-2-nic1 -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:52:45:33:42:41 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:43:27:42:36:36
2.submit the job.
Guest 2:
/usr/libexec/qemu-kvm -m 2G -M pc -smp 2,cores=2 -cpu Penryn -usb -device usb-tablet -drive file=win8-64-new-nic2.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 281ce10e-f1a8-4d99-affe-939ef8c60f8c -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win864-netkvm-1.6.7-2-nic2,server,nowait -mon chardev=a11,mode=readline -vnc :4 -vga cirrus -chardev socket,id=channel0,path=/tmp/ttnic2,server,nowait -name win8-64-netkvm-1.6.7-2-nic2 -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:43:25:36:22:11 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:43:48:43:26:37

Actual results:
The job can pass without any errors
Expected results:
The job failed due to Exceptions from test app on guest1
Additional info:
Enable S3 and S4 hit bug Bug 1057543
Disable S3 and S4 hit this bug please see the screen shots.

Comment 1 Min Deng 2014-01-27 09:37:49 UTC
Enable S3 and Disable 4 still hit the same issue.Hck file will be uploaded in a minute.

Comment 3 Min Deng 2014-01-27 10:07:02 UTC
Created attachment 855997 [details]
HCKfile

Comment 4 lijin 2014-01-28 05:30:32 UTC
win8.1-64 hit the same issue,steps same as comment0

Comment 5 Yan Vugenfirer 2014-02-12 10:55:41 UTC
Hello,

Please test power transition tests with QXL only (Win7, Win8 and Win8.1).

In general the test application crashed on the test client. But I think that part of the reason is that s3 is not supported without QXL.

Closing. Please retest with QXL.

Thanks,
Yan.

Comment 6 Mike Cao 2014-02-12 11:36:35 UTC
(In reply to Yan Vugenfirer from comment #5)
> Hello,
> 
> Please test power transition tests with QXL only (Win7, Win8 and Win8.1).
> 
> In general the test application crashed on the test client. But I think that
> part of the reason is that s3 is not supported without QXL.
> 
> Closing. Please retest with QXL.
> 
> Thanks,
> Yan.
re-open ,QE are using QXL for the SUT (guest1)

Comment 12 Min Deng 2014-10-17 09:44:04 UTC
Created attachment 947855 [details]
win81-64

Comment 14 Yossi Hindin 2015-01-29 14:39:08 UTC
Hi

I have a question on the test environment: did you install QXL VGA driver inside quests? Without QXL VGA driver, Windows 8.1 can't be put to sleep and the test should fail.

    Regards,
       Joseph Hindin

Comment 15 Mike Cao 2015-01-30 02:51:54 UTC
(In reply to Yossi Hindin from comment #14)
> Hi
> 
> I have a question on the test environment: did you install QXL VGA driver
> inside quests? Without QXL VGA driver, Windows 8.1 can't be put to sleep and
> the test should fail.
> 
>     Regards,
>        Joseph Hindin

yes referring to comment#11, We will retest on build 100 recently

Comment 16 Yossi Hindin 2015-02-01 18:32:47 UTC
Hi

I am trying to reproduce the problem, but run into several problems with the QXL WMMD driver. If you've made any progress with WMMD graphics, please, let me know.

    Regards,
       Joseph Hindin

Comment 17 Vadim Rozenfeld 2015-02-07 03:15:29 UTC
(In reply to Yossi Hindin from comment #16)
> Hi
> 
> I am trying to reproduce the problem, but run into several problems with the
> QXL WMMD driver. If you've made any progress with WMMD graphics, please, let
> me know.
> 
>     Regards,
>        Joseph Hindin


Can we try switching back to VGA mode by adding the following parameter to qemu command line "qxl-vga.revision=3" ?
For HCK purpose only, I would suggest running QXL WDDM driver in VGA mode.

Cheers,
Vadim.

Comment 18 lijin 2015-02-12 05:55:43 UTC
try with qxl-vga.revision=3 and qxlwddm-0.1-6.zip,this job can pass on win8-32/64,win8.1-32/64

package info:
qemu-kvm-rhev-2.1.2-20.el7.x86_64
kernel-3.10.0-223.el7.x86_64
seabios-1.7.5-4.el7.x86_64
virtio-win-prewhql-100

Comment 19 Mike Cao 2015-02-12 05:57:41 UTC
Based on comment#18 ,looks it is wddm-qxl issue.

Comment 20 Mike Cao 2015-02-12 06:10:54 UTC
(In reply to Mike Cao from comment #19)
> Based on comment#18 ,looks it is wddm-qxl issue.

Sorry ,Ignore this comment 

I still can hit the issue both on win7-32/64 when running  PM_PowerStateTransition job on virtio-win-prewhql-100

Mike

Comment 21 Yan Vugenfirer 2015-02-12 08:15:17 UTC
(In reply to Mike Cao from comment #20)
> (In reply to Mike Cao from comment #19)
> > Based on comment#18 ,looks it is wddm-qxl issue.
> 
> Sorry ,Ignore this comment 
> 
> I still can hit the issue both on win7-32/64 when running 
> PM_PowerStateTransition job on virtio-win-prewhql-100
> 
> Mike

Hi Mike,

Can you open separate bug for Windows 7 as we use different versions of qxl driver for the versification?

Thank,
Yan.

Comment 22 Mike Cao 2015-02-12 08:19:52 UTC
(In reply to Yan Vugenfirer from comment #21)
> (In reply to Mike Cao from comment #20)
> > (In reply to Mike Cao from comment #19)
> > > Based on comment#18 ,looks it is wddm-qxl issue.
> > 
> > Sorry ,Ignore this comment 
> > 
> > I still can hit the issue both on win7-32/64 when running 
> > PM_PowerStateTransition job on virtio-win-prewhql-100
> > 
> > Mike
> 
> Hi Mike,
> 
> Can you open separate bug for Windows 7 as we use different versions of qxl
> driver for the versification?
> 
> Thank,
> Yan.

OK

Comment 23 Yan Vugenfirer 2015-02-12 10:03:30 UTC
(In reply to Mike Cao from comment #19)
> Based on comment#18 ,looks it is wddm-qxl issue.

wddm-qxl is under development. So if you can pass certification with specific version, let's close the bug and have a wiki entry describing correct configuration for Windows 8/8.1.

Thanks.

Comment 25 Yossi Hindin 2015-02-15 16:43:29 UTC
Hi

I still have problems running the test setup - while qxlwddm-0.1-6 with "qxl-vga.revision=3" option appear to work, the test apparently stalls, I suspect that the failure is related to S3 transition.

I have notices also that QA team is running the test with options "-global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1". The HCK failure is expected under these options, as they disable S3 transition. IMHO, the proper options values are "-global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0" - at least, in the later case I see "Sleep" among the power options.

   Regards,

       Joseph Hindin

Comment 26 Mike Cao 2015-02-16 02:44:07 UTC
(In reply to Yossi Hindin from comment #25)
> Hi
> 
> I still have problems running the test setup - while qxlwddm-0.1-6 with
> "qxl-vga.revision=3" option appear to work, the test apparently stalls, I
> suspect that the failure is related to S3 transition.

lijin ,Can you try to reproduce it ? As you clmains it can pass on c#18.

> 
> I have notices also that QA team is running the test with options "-global
> PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1". The HCK failure is
> expected under these options, as they disable S3 transition. IMHO, the
> proper options values are "-global PIIX4_PM.disable_s3=0 -global
> PIIX4_PM.disable_s4=0" - at least, in the later case I see "Sleep" among the
> power options.

The history is we always enable pm support during testing before but lots of testing failed due to s3/s4 issue ,then after serveral years testing ,we found s3/s4 is not necessary for some jobs even it named Sleep and PNP ,Sleep and IO . Our strategy is disable s3/s4 in default ,rerun the failed job w/ s3/s4 enabled now 

Thanks,
Mike

Comment 27 lijin 2015-02-16 03:16:59 UTC
in comment #18,we tested with "-global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0",job can pass,test did NOT stall

the full qemu command:
NIC1:
/usr/libexec/qemu-kvm -name 100NICBLUE64CBG -enable-kvm -m 2G -smp 4 -uuid ad347ae7-b7af-48be-a9c4-09e8e836b181 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/100NICBLUE64CBG,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=100NICBLUE64CBG,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=100NICBLUE64CBG.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:4e:13:1a:49,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:45:44:d7:24,bus=pci.0,mq=on,vectors=10 -spice disable-ticketing,port=5902 -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -global qxl-vga.revision=3

NIC2:
/usr/libexec/qemu-kvm -name 100NICBLUE64SBG -enable-kvm -m 2G -smp 4 -uuid e1f92aaa-6925-45c4-ac01-6eaa6a6720fa -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/100NICBLUE64SBG,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=100NICBLUE64SBG,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x64_dvd_2971902.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=100NICBLUE64SBG.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:21:64:98:e6,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:0d:6e:a0:6e,bus=pci.0,mq=on,vectors=10 -spice disable-ticketing,port=5903 -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -global qxl-vga.revision=3

Comment 28 Yan Vugenfirer 2015-02-19 12:36:05 UTC
(In reply to lijin from comment #27)
> in comment #18,we tested with "-global PIIX4_PM.disable_s3=0 -global
> PIIX4_PM.disable_s4=0",job can pass,test did NOT stall
> 

Did the test pass?

Comment 29 lijin 2015-02-26 02:36:55 UTC
(In reply to Yan Vugenfirer from comment #28)
> (In reply to lijin from comment #27)
> > in comment #18,we tested with "-global PIIX4_PM.disable_s3=0 -global
> > PIIX4_PM.disable_s4=0",job can pass,test did NOT stall
> > 
> 
> Did the test pass?

yes,the test passed

Comment 32 lijin 2015-03-30 06:38:41 UTC
with build101,job can pass on win8,win8.1 guests.
so this issue has been fixed already.

Comment 35 lijin 2015-07-17 06:59:10 UTC
change status to verified according to comment#32

Comment 37 errata-xmlrpc 2015-11-24 08:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.