Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058200 - qemu-kvm will core dump when boot with >=50 pci-bridge(pci-bridge behind pci-bridge)
Summary: qemu-kvm will core dump when boot with >=50 pci-bridge(pci-bridge behind pci-...
Keywords:
Status: CLOSED DUPLICATE of bug 1342434
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1176553
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 08:47 UTC by Jun Li
Modified: 2017-02-14 10:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1260932 (view as bug list)
Environment:
Last Closed: 2017-02-14 10:27:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1058597 None None None Never
Red Hat Bugzilla 1058622 None None None Never

Internal Links: 1058597 1058622

Comment 10 jingzhao 2017-02-14 09:58:22 UTC
Reproduced on qemu-kvm-1.5.3-131.el7.x86_64

Following is the test result

qemu-kvm: /builddir/build/BUILD/qemu-1.5.3/savevm.c:1724: register_savevm_live: Assertion `!se->compat || se->instance_id == 0' failed.

(gdb) bt
#0  0x00007fffed7931d7 in raise () at /lib64/libc.so.6
#1  0x00007fffed7948c8 in abort () at /lib64/libc.so.6
#2  0x00007fffed78c146 in __assert_fail_base () at /lib64/libc.so.6
#3  0x00007fffed78c1f2 in  () at /lib64/libc.so.6
#4  0x0000555555778f5c in register_savevm_live (dev=dev@entry=0x55555aa3f1e8, idstr=idstr@entry=0x5555558638d8 "virtio-blk", instance_id=<optimized out>, version_id=version_id@entry=2, ops=<optimized out>, opaque=opaque@entry=0x55555aa3f1e8)
    at /usr/src/debug/qemu-1.5.3/savevm.c:1724
#5  0x0000555555778fc3 in register_savevm (dev=dev@entry=0x55555aa3f1e8, idstr=idstr@entry=0x5555558638d8 "virtio-blk", instance_id=<optimized out>, version_id=version_id@entry=2, save_state=save_state@entry=0x5555557370c0 <virtio_blk_save>, load_state=0x55555aa3f1e8, 
    load_state@entry=0x555555737d40 <virtio_blk_load>, opaque=opaque@entry=0x55555aa3f1e8) at /usr/src/debug/qemu-1.5.3/savevm.c:1741
#6  0x0000555555736fe6 in virtio_blk_device_init (vdev=0x55555aa3f1e8) at /usr/src/debug/qemu-1.5.3/hw/block/virtio-blk.c:742
#7  0x0000555555764366 in virtio_device_init (qdev=0x55555aa3f1e8) at /usr/src/debug/qemu-1.5.3/hw/virtio/virtio.c:1203
#8  0x000055555563f714 in device_realize (dev=0x55555aa3f1e8, err=0x7fffffffc850) at hw/core/qdev.c:178
#9  0x000055555564067b in device_set_realized (obj=0x55555aa3f1e8, value=<optimized out>, err=0x7fffffffc940) at hw/core/qdev.c:693
#10 0x00005555556e85de in property_set_bool (obj=0x55555aa3f1e8, v=<optimized out>, opaque=0x55555aad4390, name=<optimized out>, errp=0x7fffffffc940) at qom/object.c:1302
#11 0x00005555556ea6b7 in object_property_set_qobject (obj=0x55555aa3f1e8, value=<optimized out>, name=0x5555558435ca "realized", errp=0x7fffffffc940) at qom/qom-qobject.c:24
#12 0x00005555556e98a0 in object_property_set_bool (obj=obj@entry=0x55555aa3f1e8, value=value@entry=true, name=name@entry=0x5555558435ca "realized", errp=errp@entry=0x7fffffffc940) at qom/object.c:853
#13 0x000055555563faea in qdev_init (dev=dev@entry=0x55555aa3f1e8) at hw/core/qdev.c:163
#14 0x00005555556a352b in virtio_blk_pci_init (vpci_dev=0x55555aa3ea00) at hw/virtio/virtio-pci.c:1091
#15 0x00005555556a38b2 in virtio_pci_init (pci_dev=<optimized out>) at hw/virtio/virtio-pci.c:1027
#16 0x0000555555677032 in pci_qdev_init (qdev=0x55555aa3ea00) at hw/pci/pci.c:1723
#17 0x000055555563f714 in device_realize (dev=0x55555aa3ea00, err=0x7fffffffca70) at hw/core/qdev.c:178
#18 0x000055555564067b in device_set_realized (obj=0x55555aa3ea00, value=<optimized out>, err=0x7fffffffcb98) at hw/core/qdev.c:693
#19 0x00005555556e85de in property_set_bool (obj=0x55555aa3ea00, v=<optimized out>, opaque=0x55555aad4190, name=<optimized out>, errp=0x7fffffffcb98) at qom/object.c:1302
#20 0x00005555556ea6b7 in object_property_set_qobject (obj=0x55555aa3ea00, value=<optimized out>, name=0x5555558435ca "realized", errp=0x7fffffffcb98) at qom/qom-qobject.c:24
#21 0x00005555556e98a0 in object_property_set_bool (obj=obj@entry=0x55555aa3ea00, value=value@entry=true, name=name@entry=0x5555558435ca "realized", errp=errp@entry=0x7fffffffcb98) at qom/object.c:853
---Type <return> to continue, or q <return> to quit---
#22 0x00005555556d532f in qdev_device_add (opts=0x555556cd3ea0) at qdev-monitor.c:556
#23 0x0000555555714e39 in device_init_func (opts=<optimized out>, opaque=<optimized out>) at vl.c:2297
#24 0x000055555582de8b in qemu_opts_foreach (list=<optimized out>, func=func@entry=
    0x555555714e30 <device_init_func>, opaque=opaque@entry=0x0, abort_on_failure=abort_on_failure@entry=1) at util/qemu-option.c:1198
#25 0x00005555555ca1d1 in main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4253


Thanks
Jing Zhao

Comment 11 Dr. David Alan Gilbert 2017-02-14 10:27:11 UTC

*** This bug has been marked as a duplicate of bug 1342434 ***


Note You need to log in before you can comment on or make changes to this bug.