Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058185 - Build from glusterfs.spec fails on EPEL-5 because of BuildRequires lvm2-devel
Summary: Build from glusterfs.spec fails on EPEL-5 because of BuildRequires lvm2-devel
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-27 07:51 UTC by Niels de Vos
Modified: 2014-02-03 11:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-03 11:55:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
root.log from http://copr-be.cloud.fedoraproject.org/results/devos/glusterfs-3.4/epel-5-x86_64/glusterfs-3.4.20140127.8eda793-1.autobuild/ (deleted)
2014-01-30 12:03 UTC, Niels de Vos
no flags Details

Description Niels de Vos 2014-01-27 07:51:55 UTC
Caught in autobuilding:

DEBUG util.py:281:  Getting requirements for glusterfs-3.5.20140126.aa1c0e7-1.src
DEBUG util.py:281:   --> bison-2.3-2.1.x86_64
DEBUG util.py:281:   --> flex-2.5.4a-41.fc6.x86_64
DEBUG util.py:281:   --> Already installed : gcc-4.1.2-54.el5.x86_64
DEBUG util.py:281:   --> Already installed : 1:make-3.81-3.el5.x86_64
DEBUG util.py:281:   --> automake-1.9.6-2.3.el5.noarch
DEBUG util.py:281:   --> libtool-1.5.22-7.el5_4.x86_64
DEBUG util.py:281:   --> ncurses-devel-5.5-24.20060715.x86_64
DEBUG util.py:281:   --> readline-devel-5.1-3.el5.x86_64
DEBUG util.py:281:   --> libxml2-devel-2.6.26-2.1.21.el5_9.3.x86_64
DEBUG util.py:281:   --> openssl-devel-0.9.8e-26.el5_9.1.x86_64
DEBUG util.py:281:   --> libaio-devel-0.3.106-5.x86_64
DEBUG util.py:281:   --> python-devel-2.4.3-56.el5.x86_64
DEBUG util.py:281:   --> python-ctypes-1.0.2-3.el5.x86_64
DEBUG util.py:281:  Error: No Package found for lvm2-devel
DEBUG util.py:371:  Child return code was: 1

Comment 1 Niels de Vos 2014-01-30 12:02:30 UTC
The .spec seems to be correct...

...
%if ( 0%{?rhel} && 0%{?rhel} < 6 || 0%{?sles_version} )
%define _without_bd --disable-bd-xlator
%endif
...
%if ( 0%{!?_without_bd:1} )
BuildRequires:    lvm2-devel
%endif
...

A local 'mock -r epel-5-x86_64 ...' works, it seems to be a COPR issue?

Comment 3 Miroslav Suchý 2014-02-03 10:01:58 UTC
Really - in Copr those macros was not defined.
This issue should be now fixed. Your package should build in epel-5-* now.

Comment 4 Niels de Vos 2014-02-03 11:55:06 UTC
(In reply to Miroslav Suchý from comment #3)
> Really - in Copr those macros was not defined.
> This issue should be now fixed. Your package should build in epel-5-* now.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.