Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058030 - Incorrect error message when trying to edit network attached to Template from VM to non-VM
Summary: Incorrect error message when trying to edit network attached to Template from...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 3.4.0
Assignee: Moti Asayag
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-26 14:49 UTC by GenadiC
Modified: 2014-04-01 05:06 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:26 UTC
oVirt Team: ---


Attachments (Terms of Use)
screenshot with incorrect error message (deleted)
2014-01-26 14:49 UTC, GenadiC
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24997 None MERGED engine: Print correct message for network used by templates Never
oVirt gerrit 25141 None MERGED engine: Print correct message for network used by templates Never

Description GenadiC 2014-01-26 14:49:07 UTC
Created attachment 855685 [details]
screenshot with incorrect error message

Description of problem:
When trying to edit network from VM to non-VM and that network is attached to VM, the action should fail with error message that network is attached to the Template. Instead of that we get an error message that the network is attached to VM.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create VM network
2. Attach it to the Template
3. Try to edit Network from VM to non-VM

Actual results:
The action fails with error message: Error while executing action: Cannot edit Network. Several virtual machines (1) are using this logical network:
Temp_VM1
- Please remove it from all virtual machines that are using it and try again.

Expected results:
The action should fail but the message should include Template instead of VM as the action failed because the network is attached to the Template

Additional info:

Comment 1 Moti Asayag 2014-02-25 10:04:46 UTC
This is more severe than the text message: the engine didn't block the network from being changed to non-vm network if it was in use by templates, which could eventually lead to a vm configured to use a non vm network.

Comment 2 Moti Asayag 2014-02-25 10:20:15 UTC
(In reply to Moti Asayag from comment #1)
> This is more severe than the text message: the engine didn't block the
> network from being changed to non-vm network if it was in use by templates,
> which could eventually lead to a vm configured to use a non vm network.

Reverting this comment...seems we the engine do block it, just with improper description.

Comment 3 Sandro Bonazzola 2014-03-03 14:40:21 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 4 GenadiC 2014-03-03 15:45:48 UTC
Verified with av2

Comment 5 Sandro Bonazzola 2014-03-31 12:29:26 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.