Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1058010 - systemd doesn't run init.d services
Summary: systemd doesn't run init.d services
Keywords:
Status: CLOSED DUPLICATE of bug 1057635
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Nykrýn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-26 12:27 UTC by Account closed by the user
Modified: 2014-01-30 11:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-30 11:13:55 UTC


Attachments (Terms of Use)

Description Account closed by the user 2014-01-26 12:27:08 UTC
the last update (systemd-208-11.fc20.x86_64) broke init.d services.


# /etc/init.d/network start
Starting network (via systemctl):  Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.
                                                           [FAILED]


# journalctl -xn
-- Logs begin at Sun 2014-01-19 11:50:01 CET, end at Sun 2014-01-26 13:22:54 CET. --
Jan 26 13:22:46 querida.micasa.es kernel: cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm)
Jan 26 13:22:46 querida.micasa.es kernel: cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
Jan 26 13:22:54 querida.micasa.es systemd[1]: Starting LSB: Bring up/down networking...
-- Subject: Unit network.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit network.service has begun starting up.
Jan 26 13:22:54 querida.micasa.es network[7151]: Bringing up loopback interface:  [  OK  ]
Jan 26 13:22:54 querida.micasa.es network[7151]: Bringing up interface wlp10s0:  [FAILED]
Jan 26 13:22:54 querida.micasa.es systemd[1]: network.service: control process exited, code=exited status=1
Jan 26 13:22:54 querida.micasa.es systemd[1]: Failed to start LSB: Bring up/down networking.
-- Subject: Unit network.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit network.service has failed.
-- 
-- The result is failed.
Jan 26 13:22:54 querida.micasa.es systemd[1]: Unit network.service entered failed state.
Jan 26 13:22:54 querida.micasa.es systemd[1]: Starting Network.
-- Subject: Unit network.target has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit network.target has begun starting up.
Jan 26 13:22:54 querida.micasa.es systemd[1]: Reached target Network.
-- Subject: Unit network.target has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit network.target has finished starting up.
-- 
-- The start-up result is done.

Comment 1 Lennart Poettering 2014-01-28 00:31:56 UTC
well, systemd certainly starts the "network" init script, however that script then fails with exit code 1. Reassinging to the "Initscripts" package, hence.

Comment 2 Account closed by the user 2014-01-28 00:36:58 UTC
(In reply to Lennart Poettering from comment #1)

> well, systemd certainly starts the "network" init script, however that
> script then fails with exit code 1. Reassinging to the "Initscripts"
> package, hence.

initscripts-9.51-1.fc20.x86_64

/etc/sysconfig/network-scripts/ifcfg-wlp10s0:
TYPE=Ethernet
HWADDR="77:66:44:33:55:22"
DEVICE="wlp10s0"
BOOTPROTO=none
ONBOOT=yes
NM_CONTROLLED=no
IPADDR=192.168.0.2
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
IPV6INIT=no
USERCTL=no

Comment 3 Lukáš Nykrýn 2014-01-30 11:13:55 UTC

*** This bug has been marked as a duplicate of bug 1057635 ***


Note You need to log in before you can comment on or make changes to this bug.