Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057966 - Can not login to the system after a while
Summary: Can not login to the system after a while
Keywords:
Status: CLOSED DUPLICATE of bug 1043212
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-26 08:32 UTC by Lars E. Pettersson
Modified: 2014-02-23 15:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-23 15:52:57 UTC


Attachments (Terms of Use)

Description Lars E. Pettersson 2014-01-26 08:32:03 UTC
Description of problem:

I start the computer. Login at the login screen. Start up Firefox and Thunderbird. Does some other stuff, start gnome-terminal or whatever. Leave the system. The lock screen turns on. Returns to the system. Tries to login and is greeted with 'System is booting up. See pam_nologin(8)', after giving the correct password. Trying ssh in to the machine, and is greeted with the same message. Only solution left is to power off the machine, and turn it on again, potentially losing important data not saved earlier.

Version-Release number of selected component (if applicable):

systemd-208-9.fc20.x86_64

How reproducible:

Happens once in while...

Steps to Reproduce:
1. See above (have happened some 5-10 times since Fedora 20)
2.
3.

Actual results:

See above...

Expected results:

A functional system that allows me to leave the system, and login at the lock screen without being greeted with 'System is booting up. See pam_nologin(8)'

Additional info:

System is updated from Fedora 19.

Comment 1 Lars E. Pettersson 2014-01-26 09:26:05 UTC
Noticed the following in the logs:

Jan 26 09:02:23 localhost systemd-tmpfiles: Unable to fix label of /run/log/journal/748778b0c456495f88c9048c7efd55ac: No such file or directory
Jan 26 09:02:23 localhost systemd-tmpfiles: Unable to fix label of /run/log/journal: No such file or directory

Why is it looking in /run/log? The journal is in /var/log:

$ ll /var/log/journal/
total 8
drwxr-sr-x+ 2 root systemd-journal 4096 Jan 26 09:02 748778b0c456495f88c9048c7efd55ac

Also noted the following yum updates done during the time the system was idle (i.e. in lock screen):

Jan 26 09:02:07 Updated: tigervnc-icons.noarch 1.3.0-12.fc20
Jan 26 09:02:07 Updated: tigervnc-license.noarch 1.3.0-12.fc20
Jan 26 09:02:11 Updated: tigervnc.x86_64 1.3.0-12.fc20
Jan 26 09:02:11 Updated: rtkit.x86_64 0.11-8.fc20
Jan 26 09:02:14 Updated: libvirt-client.x86_64 1.1.3.3-2.fc20
Jan 26 09:02:16 Updated: gnome-shell.x86_64 3.10.3-2.fc20

Could the gnome-shell update have done something here?

Comment 2 Lennart Poettering 2014-01-28 00:31:13 UTC
I have the suspicion that one of the packages you updated there actually runs "tmpfiles" in a way it better shouldn't run it, which results in /etc/nologin to be created.

Comment 3 Lars E. Pettersson 2014-01-28 08:33:25 UTC
OK, I'll take a closer look the next time this happens. I have no direct clue on what happened the other 4-9 times, but I can look a bit closer in the logs to see if I can find those times, and see what was going on then.

I find it a bit strange that systemd-tmpfiles mentions /run/log/journal/748778b0c456495f88c9048c7efd55ac when the journals are being kept in /var/log/journal. Is this a problem in systemd-tmpfiles, or the program calling systemd-tmpfiles?

Comment 4 Ray Strode [halfline] 2014-02-06 18:49:26 UTC
see bug 1043212

Comment 5 Lennart Poettering 2014-02-23 15:52:57 UTC

*** This bug has been marked as a duplicate of bug 1043212 ***


Note You need to log in before you can comment on or make changes to this bug.