Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057956 - It always exists some error message with "Failed to get information from haproxy" in the scale_events.log as it is normal
Summary: It always exists some error message with "Failed to get information from hapr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On: 1044927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-26 07:06 UTC by Gaoyun Pei
Modified: 2017-03-08 17:36 UTC (History)
5 users (show)

Fixed In Version: openshift-origin-cartridge-haproxy-1.17.3.4-1.el6op
Doc Type: Bug Fix
Doc Text:
While successfully creating or scaling an application, the scale_events.log file on HAProxy cartridges displayed this error message: "Failed to get information from haproxy". This occurred due to common HAProxy operations and was potentially confusing because there was no actual problem. This bug fix suppresses the messages during such operations and now the logs do not show extraneous error messages. The following command must be run after applying this fix: # oo-admin-upgrade upgrade-node --version=2.0.3 See the Solution section in the errata advisory for full details.
Clone Of: 1044927
Environment:
Last Closed: 2014-02-25 15:44:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0209 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.0.3 bugfix and enhancement update 2014-02-25 20:40:32 UTC

Description Gaoyun Pei 2014-01-26 07:06:55 UTC
This issue exists in puddle 2.0.z/2014-01-24.1, we should pick up this patch to ose.

+++ This bug was initially created as a clone of Bug #1044927 +++

Description of problem:
When ssh into a scale app, cat the scale_events.log file, it always exists some error message like this "Failed to get information from haproxy" and the scale app is normal.
Version-Release number of selected component (if applicable):
devenv_4156
How reproducible:
always
Steps to Reproduce:
1. Create a app 
#rhc app create pys python-2.7 -s.
2. cat haproyx/logs/scale_events.log
#cat /var/lib/openshift/$uuid/haproyx/logs/scale_events.log
Actual results:
[pys26-nweidevenv.dev.rhcloud.com 52b2a29bd132304f02000040]\> cat haproxy/logs/scale_events.log 
E, [2013-12-19T02:39:30.712170 #23014] ERROR -- : Failed to get information from haproxy
Expected results:
There are no error message if the message is correct.
Additional info:

--- Additional comment from Dan McPherson on 2014-01-23 23:45:05 EST ---

https://github.com/openshift/origin-server/pull/4583

--- Additional comment from openshift-github-bot on 2014-01-24 00:55:55 EST ---

Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/dfd3d548db76b42de13cbe06f77260daa4a17ab0
Bug 1044927

--- Additional comment from Nan Wei on 2014-01-24 04:48:05 EST ---

Version-Release number of selected component (if applicable):
devenv_4270

1. Create a app 
#rhc app create perls perl-5.10 -s.

2. ssh app and cat haproyx/logs/scale_events.log
[perls-nweid.dev.rhcloud.com 52e235f8f305d2f3da000046]\> cat haproxy/logs/scale_events.log
I, [2014-01-24T04:45:10.513795 #15750]  INFO -- : Starting haproxy_ctld

There are no error message, so verify it.

Comment 5 Gaoyun Pei 2014-01-28 03:34:51 UTC
verify this issue with openshift-origin-cartridge-haproxy-1.17.3.4-1.el6op

Create a scalable app, scale-up and scale-down several times, check the scale_event.log, no "ERROR -- : Failed to get information from haproxy" appeared.

Comment 7 errata-xmlrpc 2014-02-25 15:44:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0209.html


Note You need to log in before you can comment on or make changes to this bug.