Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057945 - [whql]KVM internal error. Suberror: 1 when win7-64 guest run HCK jobs
Summary: [whql]KVM internal error. Suberror: 1 when win7-64 guest run HCK jobs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Radim Krčmář
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-26 05:46 UTC by Min Deng
Modified: 2014-11-18 18:59 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 18:56:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Min Deng 2014-01-26 05:46:49 UTC
Description of problem:
While running WHQL jobs on win7-64 guests it could get "KVM internal error" issue
WHQL jobs were 
DF - PNP Rebalance Fail Restart Device Test (Certification)
Windows Logo Kit- Prepare client for submission
Version-Release number of selected component (if applicable):
kernel-3.10.0-64.el7.x86_64
qemu-kvm-rhev-1.5.3-30.el7.x86_64
build virtio-win-1.6.7.2

How reproducible:
DF - PNP Rebalance Fail Restart Device Test (Certification)
Windows Logo Kit- Prepare client for submission


Steps to Reproduce:
1.boot up guest with 
  /usr/libexec/qemu-kvm -m 2G -M pc -smp 2,cores=2 -cpu Penryn -usb -device usb-tablet -drive file=win7-64-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid a2ebfe3e-9930-4358-9bcc-3c81e1bb3302 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win764-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :3 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win7-64-netkvm-1.6.7-2-nic1 -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:53:07:53:22:51 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:42:41:56:21:38
2.submit job to hck 2.1
3.

Actual results:
The guest got the below error message and job could not continue.

  (qemu) KVM internal error. Suberror: 1
emulation failure
RAX=000000001fbc1863 RBX=0000000000000863 RCX=000000000001fbc1 RDX=fffff6fb7dbedf90
RSI=0000000000000002 RDI=fffff88004a29000 RBP=fffffa80005f3430 RSP=fffff88003e21ad0
R8 =ffffffffffffffff R9 =0000000000000007 R10=fffffa80018013b0 R11=fffff88003e21aa0
R12=000000000001fbc1 R13=0000000000000000 R14=000000000000003f R15=fffff880009e6180
RIP=fffff80002b0d31f RFL=00010206 [-----P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
CS =0010 0000000000000000 00000000 00209b00 DPL=0 CS64 [-RA]
SS =0018 0000000000000000 ffffffff 00c09300 DPL=0 DS   [-WA]
DS =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
FS =0053 00000000fffda000 00007c00 0040f300 DPL=3 DS   [-WA]
GS =002b fffff880009e6000 ffffffff 00c0f300 DPL=3 DS   [-WA]
LDT=0000 0000000000000000 ffffffff 00c00000
TR =0040 fffff880009eaec0 00000067 00008b00 DPL=0 TSS64-busy
GDT=     fffff880009f14c0 0000007f
IDT=     fffff880009f1540 00000fff
CR0=80050031 CR2=fffff80002b0d133 CR3=0000000020449000 CR4=000006f8
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000d01
Code=?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? <??> ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ??


Expected results:
The job can pass

Additional info:
Per Developer I reported the bug - Bug 1050775,the issue wasn't always reproduced.

Comment 2 lijin 2014-01-27 03:21:02 UTC
win8.1-64 sometimes hit similar issue when running some hck jobs
(qemu) KVM internal error. Suberror: 1
emulation failure
RAX=ffffd00023ce6000 RBX=ffffe00003091000 RCX=0000000000800000 RDX=ffffd00023ce6000
RSI=ffffcf800074cf70 RDI=0000000000000000 RBP=0000000000002180 RSP=ffffd00020968c60
R8 =000000007c000000 R9 =fffff6f000018404 R10=0000000000000001 R11=ffffe00003091000
R12=ffffd00020968dbc R13=ffffd00020968e08 R14=0000000000000000 R15=ffffe000030c6005
RIP=fffff8000180e657 RFL=00010246 [---Z-P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
CS =0010 0000000000000000 00000000 00209b00 DPL=0 CS64 [-RA]
SS =0018 0000000000000000 ffffffff 00c09300 DPL=0 DS   [-WA]
DS =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
FS =0053 00000000a1690000 00007c00 0040f300 DPL=3 DS   [-WA]
GS =002b ffffd00020de7000 ffffffff 00c0f300 DPL=3 DS   [-WA]
LDT=0000 0000000000000000 ffffffff 00c00000
TR =0040 ffffd00020ded2c0 00000067 00008b00 DPL=0 TSS64-busy
GDT=     ffffd00020df4280 0000007f
IDT=     ffffd00020df4300 00000fff
CR0=80050031 CR2=fffff8000180e38e CR3=00000000001a7000 CR4=000406f8
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000d01
Code=?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? <??> ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ??

Comment 14 Mike Cao 2014-02-05 00:03:34 UTC
you can find the latestcode from https://github.com/vipmike007/whql_powershell/netkvm.ps1,it works for all drivers

Comment 18 Mike Cao 2014-04-25 03:35:19 UTC
I hit this issue as well on win7-64 when running virito-rng whql Job DF - Fuzz misc API with zero length query test (Certification) .but the job can pass at last 
Packages
3.10.0-121.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64
seabios-bin-1.7.2.2-12.el7.x86_64
virtio-win-prewhql-80



/usr/libexec/qemu-kvm -name 080RNGWIN764GA5 -enable-kvm -m 2G -smp 2 -uuid 0c3138c0-d7b2-4b4b-91e8-0bc1833dd4ec -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/080RNGWIN764GA5,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=080RNGWIN764GA5,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=080RNGWIN764GA5.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:4e:57:16:2c,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0:2 -vga cirrus -object rng-random,filename=/dev/urandom,id=rng0 -device virtio-rng-pci,rng=rng0
the qemu-kvm is start , pid is 54166
char device redirected to /dev/pts/10 (label charserial0)



KVM internal error. Suberror: 1
emulation failure
RAX=0000000003000600 RBX=fffffa8003ae2000 RCX=fffff8800326a000 RDX=000000000000b008
RSI=fffffa8003a5d4e0 RDI=0000000000000000 RBP=0000000000002180 RSP=fffff88003116110
R8 =0000000001000000 R9 =fffff6fd4001d700 R10=0000000000800000 R11=0000000000000000
R12=fffff88003116280 R13=fffff88003116318 R14=0000000000000001 R15=0000000000000001
RIP=fffff880036726b9 RFL=00010286 [--S--P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
CS =0010 0000000000000000 00000000 00209b00 DPL=0 CS64 [-RA]
SS =0018 0000000000000000 ffffffff 00c09300 DPL=0 DS   [-WA]
DS =002b 0000000000000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
FS =0053 00000000fffe0000 00007c00 0040f300 DPL=3 DS   [-WA]
GS =002b fffff880009e6000 ffffffff 00c0f300 DPL=3 DS   [-WA]
LDT=0000 0000000000000000 ffffffff 00c00000
TR =0040 fffff880009eaec0 00000067 00008b00 DPL=0 TSS64-busy
GDT=     fffff880009f14c0 0000007f
IDT=     fffff880009f1540 00000fff
CR0=80050031 CR2=fffff8a00200e008 CR3=0000000000187000 CR4=000006f8
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000d01
Code=?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? <??> ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ??


Radim ,can you help to view the log above whether I need to report a new bug

Thanks,
Mike

Comment 19 Radim Krčmář 2014-04-28 20:04:34 UTC
Interesting, it looks like the same.
I found out that it doesn't happen if vpid vmx feature is enabled, but I couldn't reproduce it on newer kernels either, and bisection led to MOVAPx emulation (-114.el7) -- I don't know why, but it worked, so I let the bug stick for a bit ...

Does the new test reproduce it better than "DF - PNP rebalance [...]"?

I'd like to borrow that machine if it is possible.

Thanks.

Comment 20 juzhang 2014-04-29 00:45:38 UTC
Hi Mike,

Can you reply comment19?

Best Regards,
Junyi

Comment 27 Radim Krčmář 2014-11-18 18:56:09 UTC
The bug probably disappeared somewhere between 121.el7 and 165.el7.


Note You need to log in before you can comment on or make changes to this bug.