Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057881 - geo-rep/gfid-access : Lookup fails on /.gfid/<parent_gfid>/bname
Summary: geo-rep/gfid-access : Lookup fails on /.gfid/<parent_gfid>/bname
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-25 17:36 UTC by Kotresh HR
Modified: 2014-04-17 11:52 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-17 11:52:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2014-01-25 17:36:15 UTC
Description of problem:
Lookup fails on /.gfid/<parent_gfid>/bname and as a result
Geo-Replication does not sync symlinks and hardlinks.

Version-Release number of selected component (if applicable):


How reproducible:
Very often.

Steps to Reproduce:
1. create and start a geo-rep relationship between master and slave.
2. create files and corresponding hardlinks, symlinks to it.

Actual results: Hardlinks and symlinks not synced to slave.


Expected results: Hardlinks and symlinks should sync to slave.


Additional info:

Comment 1 Anand Avati 2014-01-25 17:39:57 UTC
REVIEW: http://review.gluster.org/6795 (features/gfid-access: fix lookup on .gfid/<parent>/bname) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 2 Anand Avati 2014-01-25 17:43:37 UTC
REVIEW: http://review.gluster.org/6795 (features/gfid-access: fix lookup on .gfid/<parent>/bname) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 3 Anand Avati 2014-01-27 08:51:48 UTC
COMMIT: http://review.gluster.org/6795 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 3a35e939ec811926f810afd792979f526f8dcce9
Author: Venky Shankar <vshankar@redhat.com>
Date:   Thu Jan 23 12:40:09 2014 +0530

    features/gfid-access: fix lookup on .gfid/<parent>/bname
    
    In gfid translator, lookup was not handling the case when
    the lookup is sent on .gfid/<parent>/bname. In this case,
    we flip with fake inode of the parent with the real inode
    in loc and send it downwards.
    
    Change-Id: I639ff1dce10ffc045da419e333d455e208b6a0f0
    BUG: 1057881
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/6795
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Anand Avati 2014-01-27 09:52:21 UTC
REVIEW: http://review.gluster.org/6807 (features/gfid-access: fix lookup on .gfid/<parent>/bname) posted (#1) for review on release-3.5 by Kotresh HR (khiremat@redhat.com)

Comment 5 Anand Avati 2014-01-27 15:52:07 UTC
COMMIT: http://review.gluster.org/6807 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit 0c80a202d475a4abb8a5738f144739234d7557c6
Author: Venky Shankar <vshankar@redhat.com>
Date:   Thu Jan 23 12:40:09 2014 +0530

    features/gfid-access: fix lookup on .gfid/<parent>/bname
    
    In gfid translator, lookup was not handling the case when
    the lookup is sent on .gfid/<parent>/bname. In this case,
    we flip with fake inode of the parent with the real inode
    in loc and send it downwards.
    
    Change-Id: I639ff1dce10ffc045da419e333d455e208b6a0f0
    BUG: 1057881
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/6795
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/6807

Comment 6 Niels de Vos 2014-04-17 11:52:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.