Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057806 - warning: ~ action is deprecated
Summary: warning: ~ action is deprecated
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Heinrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-25 00:00 UTC by Tom Horsley
Modified: 2016-12-16 08:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-21 14:08:27 UTC


Attachments (Terms of Use)

Description Tom Horsley 2014-01-25 00:00:42 UTC
Description of problem:

When rsyslogd starts I get this trash in /var/log/messages:

Jan 23 18:14:21 zooty rsyslogd-2307: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
Jan 23 18:14:21 zooty rsyslogd-2307: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
Jan 23 18:14:21 zooty rsyslogd-2307: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
Jan 23 18:14:21 zooty rsyslogd-2307: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]

So I think, fine, I'll find the new syntax I'm supposed to use to discard annoying messages.

Easier said than done. Not a single scrap of documentation anywhere describes this supposed new syntax for "stop" that replaces the supposedly deprecated tilde action. Nothing in the rsyslog.conf man page, nothing on the rsyslog web pages.

Version-Release number of selected component (if applicable):
rsyslog-7.4.2-2.fc20.x86_64

How reproducible:
every time

Steps to Reproduce:
1.boot
2.see messages in log
3.

Actual results:
deprecated feature messages

Expected results:
no deprecated feature messages without at least some hint about how to replace said deprecated feature.

Additional info:

Comment 1 Tomas Heinrich 2014-02-03 10:03:57 UTC
(In reply to Tom Horsley from comment #0)
> Easier said than done. Not a single scrap of documentation anywhere
> describes this supposed new syntax for "stop" that replaces the supposedly
> deprecated tilde action. Nothing in the rsyslog.conf man page, nothing on
> the rsyslog web pages.

> Actual results:
> deprecated feature messages
> 
> Expected results:
> no deprecated feature messages without at least some hint about how to
> replace said deprecated feature.

I agree the docs could be better.
The info you're looking for is here:

http://www.rsyslog.com/doc/v7compatibility.html

Or localaly here:

/usr/share/doc/rsyslog-doc/v7compatibility.html
from rsyslog-doc-7.4.2-2.fc20.x86_64.rpm

Comment 2 Tomas Heinrich 2014-02-21 14:08:27 UTC
I'll close this as not-a-bug since the information actually exists (even if it's not very pretty) and the warning is not emitted for the default config file.

The message is actually saying all you need to do - replace '~' with 'stop'.


Note You need to log in before you can comment on or make changes to this bug.