Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057804 - Socket avc access denied talking to (pki) Cerificate Authority
Summary: Socket avc access denied talking to (pki) Cerificate Authority
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1057801 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 23:37 UTC by Jack Magne
Modified: 2014-02-12 14:44 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.12.1-122.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-12 14:44:58 UTC


Attachments (Terms of Use)

Description Jack Magne 2014-01-24 23:37:07 UTC
Description of problem:

Problem with accessing a socket of the Certificate Authority(CA) when performing the insallation wizard for the RA (Regisration Authority). During said instalation the RA wizard uses the tool /usr/bin/sslget to contact port 8443, the secure port of the CA.


Version-Release number of selected component (if applicable):

Fedora 20, dogtag 10.x


How reproducible:

Always.


Steps to Reproduce:
1. Install a PKI CA.
2. Attempt to install a PKI RA and start the wizard.
.

Actual results:

The wizard UI will report not being able to contact the "Security Domain" of the CA.


A similar AVC to the one reported is as follows:

type=SYSCALL msg=audit(1389914018.734:951): arch=c000003e syscall=42 success=no exit=-115 a0=6 a1=7fffde8cbaf0 a2=10 a3=0 items=0 ppid=15270 pid=16498 auid=4294967295 uid=17 gid=17 euid=17 suid=17 fsuid=17 egid=17 sgid=17 fsgid=17 ses=4294967295 tty=(none) comm="sslget" exe="/usr/bin/sslget" subj=system_u:system_r:pki_ra_t:s0 key=(null)
type=AVC msg=audit(1389914049.132:952): avc:  denied  { name_connect } for  pid=16725 comm="sslget" dest=8443 scontext=system_u:system_r:pki_ra_t:s0 tcontext=system_u:object_r:http_port_t:s0 tclass=tcp_socket





Expected results:
The RA installation wizard should not be halted by this socket failure.


Additional info:

Community Reported PKI ticket for more info:

https://fedorahosted.org/pki/ticket/829

Comment 1 Christina Fu 2014-01-25 00:00:54 UTC
There is also what seems to be similar SELinux issue with TPS where TPS has permission issue binding to a port.  The following was captured in the log:

Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com systemd[1]: Starting PKI Token Processing Server pki-tps-ecc011414...
Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com pkicontrol[4554]: Starting pki-tps-ecc011414: (13)Permission denied: AH00072: make_sock: could not bind to address [::]:7888
Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com pkicontrol[4554]: (13)Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:7888
Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com pkicontrol[4554]: no listening sockets available, shutting down
Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com pkicontrol[4554]: AH00015: Unable to open logs
Jan 14 18:16:12 dhcp-16-218.sjc.redhat.com pkicontrol[4554]: [FAILED]

setenforce 0 was able to work around it.

Comment 2 Miroslav Grepl 2014-01-27 11:17:30 UTC
*** Bug 1057801 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2014-01-27 11:20:14 UTC
commit 5f588cab509eb292eec83d0d680421edb65f8109
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Jan 27 12:19:09 2014 +0100

    Allow sslget running as pki_ra_t to contact port 8443, the secure port of the CA.

Comment 4 Fedora Update System 2014-01-27 19:16:50 UTC
selinux-policy-3.12.1-121.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-121.fc20

Comment 5 Fedora Update System 2014-01-29 03:06:54 UTC
Package selinux-policy-3.12.1-121.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-121.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1700/selinux-policy-3.12.1-121.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-01-30 03:32:57 UTC
Package selinux-policy-3.12.1-122.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-122.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1700/selinux-policy-3.12.1-122.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-02-12 14:44:58 UTC
selinux-policy-3.12.1-122.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.