Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057741 - [abrt] libreoffice-core: std::__throw_length_error(): soffice.bin killed by SIGABRT
Summary: [abrt] libreoffice-core: std::__throw_length_error(): soffice.bin killed by S...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eike Rathke
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:52daab8372dd73937a1eec4ffb5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 17:32 UTC by mark_a_rodriguez
Modified: 2014-03-17 13:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-17 13:10:48 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: cgroup (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: core_backtrace (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: dso_list (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: environ (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: limits (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: maps (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: open_fds (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: proc_pid_status (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
File: var_log_messages (deleted)
2014-01-24 17:33 UTC, mark_a_rodriguez
no flags Details
libre office spreadsheet (deleted)
2014-01-24 19:12 UTC, mark_a_rodriguez
no flags Details

Description mark_a_rodriguez 2014-01-24 17:32:57 UTC
Version-Release number of selected component:
libreoffice-core-4.1.4.2-4.fc20

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///home/rodrim2/Projects/MercadoCapitales/Examples/Fed%20Monetary%20Policy%20vs%20GLD.ods --splash-pipe=5
crash_function: std::__throw_length_error
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.12.8-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            502

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 std::__throw_length_error at ../../../../../libstdc++-v3/src/c++11/functexcept.cc:76
 #7 std::vector<ScExternalRefCache::SingleRangeData, std::allocator<ScExternalRefCache::SingleRangeData> >::reserve at /usr/include/c++/4.8.2/bits/vector.tcc:69
 #8 ScExternalRefManager::getDoubleRefTokensFromSrcDoc at /usr/src/debug/libreoffice-4.1.4.2/sc/source/ui/docshell/externalrefmgr.cxx:1933
 #9 ScExternalRefManager::getDoubleRefTokens at /usr/src/debug/libreoffice-4.1.4.2/sc/source/ui/docshell/externalrefmgr.cxx:1761
 #10 ScInterpreter::GetExternalDoubleRef at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr4.cxx:1574
 #11 ScInterpreter::PopExternalDoubleRef at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr4.cxx:1526
 #13 ScInterpreter::GetMatrix at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr5.cxx:614
 #14 ScInterpreter::CalculateLookup at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr1.cxx:7086
 #15 ScInterpreter::ScVLookup at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr1.cxx:7345
 #16 ScInterpreter::Interpret at /usr/src/debug/libreoffice-4.1.4.2/sc/source/core/tool/interpr4.cxx:4078

Comment 1 mark_a_rodriguez 2014-01-24 17:33:01 UTC
Created attachment 855102 [details]
File: backtrace

Comment 2 mark_a_rodriguez 2014-01-24 17:33:06 UTC
Created attachment 855103 [details]
File: cgroup

Comment 3 mark_a_rodriguez 2014-01-24 17:33:08 UTC
Created attachment 855104 [details]
File: core_backtrace

Comment 4 mark_a_rodriguez 2014-01-24 17:33:11 UTC
Created attachment 855105 [details]
File: dso_list

Comment 5 mark_a_rodriguez 2014-01-24 17:33:12 UTC
Created attachment 855106 [details]
File: environ

Comment 6 mark_a_rodriguez 2014-01-24 17:33:14 UTC
Created attachment 855107 [details]
File: limits

Comment 7 mark_a_rodriguez 2014-01-24 17:33:15 UTC
Created attachment 855108 [details]
File: maps

Comment 8 mark_a_rodriguez 2014-01-24 17:33:17 UTC
Created attachment 855109 [details]
File: open_fds

Comment 9 mark_a_rodriguez 2014-01-24 17:33:18 UTC
Created attachment 855110 [details]
File: proc_pid_status

Comment 10 mark_a_rodriguez 2014-01-24 17:33:20 UTC
Created attachment 855111 [details]
File: var_log_messages

Comment 11 Eike Rathke 2014-01-24 18:50:30 UTC
Reason seems to be a negative tab span of the external reference.

@mark_a_rodriguez:
Do you by chance have a reproducer document that you could attach?

Comment 12 mark_a_rodriguez 2014-01-24 19:12:09 UTC
Created attachment 855157 [details]
libre office spreadsheet

I believe the problem occurred when trying to copy a sheet to a new empty document that was already opened (untitled 1).  In this case it was the "Gold" tab.

Comment 13 mark_a_rodriguez 2014-01-24 19:33:57 UTC
(In reply to mark_a_rodriguez from comment #12)
> Created attachment 855157 [details]
> libre office spreadsheet
> 
> I believe the problem occurred when trying to copy a sheet to a new empty
> document that was already opened (untitled 1).  In this case it was the
> "Gold" tab.

Perhaps a chart with a lot of points is the source of the error


Note You need to log in before you can comment on or make changes to this bug.