Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057736 - kdump to nfs that requires static routes fails due to no route configured
Summary: kdump to nfs that requires static routes fails due to no route configured
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools
Version: 6.5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: kdump team
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On: 860489
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 17:14 UTC by peter.sjoberg
Modified: 2014-01-25 01:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 860489
Environment:
Last Closed: 2014-01-25 01:56:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description peter.sjoberg 2014-01-24 17:14:54 UTC
Description of problem:
We follow /usr/share/doc/initscripts-9.03.38/sysconfig.txt and specify the static routes in ADDRESS0= format. Next we define kdump to sent the dump to a nfs share over that interface. 
During a crash the route is not added and because of that the dump can not be done.
Did also try with the depreciated format of
192.168.1.0/24 via 192.168.1.1
but still no luck.

Version-Release number of selected component (if applicable):
RHEL6.5
kexec-tools-2.0.0-258.el6_4.2.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. configure kdump to a nfs share that requires a static route
2. define the static route in /etc/sysconfig/network-scripts/route-eth0 as something like
    ADDRESS0=192.168.1.0
    NETMASK0=255.255.255.0
    GATEWAY0=192.168.1.1
3. Crash the server
  
Actual results:
busybox fails to define the static routes
it fails to mount nfs and with that no core saved


Expected results:
static routes in the recommended format works for kdump also


Additional info:
Did get it to work by adding a kdump_pre.sh file with the correct routes but would expect kdump/mkdumprd to handle it automatically instead of me having to copy the routes from /etc/sysconfig/network-scripts/route* to some custom script.

Comment 2 Baoquan He 2014-01-25 01:56:16 UTC

*** This bug has been marked as a duplicate of bug 806992 ***


Note You need to log in before you can comment on or make changes to this bug.