Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057719 - man page should mention that subscribe/unsubscribe existed and are now deprecated
Summary: man page should mention that subscribe/unsubscribe existed and are now deprec...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Deon Ballard
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel70
TreeView+ depends on / blocked
 
Reported: 2014-01-24 16:35 UTC by Adrian Likins
Modified: 2014-06-18 00:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 12:44:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 990195 None None None Never

Internal Links: 990195

Description Adrian Likins 2014-01-24 16:35:48 UTC
Description of problem:

See https://access.redhat.com/site/solutions/253273#comment-546103
and https://access.redhat.com/site/solutions/253273 in general.

There is some confusion that subscribe/unsubscribe are referenced heavily in older documentation, but are not in the man page (even thought they still work).

man page should include the commands but reference the newer named replacements
and that the old names are deprecated.



Version-Release number of selected component (if applicable):
subscription-manager-1.10.11

Comment 2 Deon Ballard 2014-01-30 03:12:05 UTC
The product documentation was already scrubbed and updated, so there should be little confusion there. As the links show, the issue is the kbase articles -- but those apply to a *specific version* of RHEL and of RHSM, so there is actually no conflict. (Presumably, the commands on RHEL 6.1 are still the same as the RHEL 6.1 man page shows.)

For a clear understanding of how the commands are changing, however, it is useful to know how the commands have changed. I added a small section in the COMMANDS/OPTIONS section of the man page for deprecated commands, and it is a simple list of what was deprecated (subscribe, unsubscribe, activate) and what replaced it (attach, remove, redeem).

Commit: 5adf26df335d2ffebb7ea4b05412580516974483

Comment 5 Sharath Dwaral 2014-02-03 23:10:07 UTC
Version

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.2-1
subscription-manager: 1.10.12-1.el7
python-rhsm: 1.10.12-1.el7


Verification:

>>Man page version:

version 2.8     January 29, 2014    subscription-manager(8)

>>List of Commands:

22. deprecated commands: subscribe, unsubscribe, and activate 


>>Commands and Options:

DEPRECATED COMMANDS
       As the structures of subscription configuration have changed, some of the original management commands have become obsolete. These commands have been replaced with updated commands.

       subscribe
              This has been replaced with attach. A similar registration option, --subscribe, has also be replaced with --autoattach.

       unsubscribe
              This has been replaced with remove.

       activate
              This has been replaced with redeem.


VERIFIED

Comment 6 Ludek Smid 2014-06-13 12:44:25 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.