Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057659 - CR2 - S-RAMP installer - if a user selects to install DTGov - then the installer must install /bin/kie.policy
Summary: CR2 - S-RAMP installer - if a user selects to install DTGov - then the instal...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR3
: 6.0.0
Assignee: Thomas Hauser
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 15:05 UTC by Len DiMaggio
Modified: 2014-02-06 15:29 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Len DiMaggio 2014-01-24 15:05:46 UTC
Description of problem:

If a user selects to install DTGov - then the installer must install /bin/kie.policy

Note that if the user selects to NOT install DTGov and selects to ONLY install S-RAMP, then the kie.policy file should not be installed. 

Version-Release number of selected component (if applicable):
CR2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Len DiMaggio 2014-01-27 12:57:26 UTC
IN CR3 - the behavior is:



Option (1) - Install S-RAMP and DT-GOV, user selects to enable Java Security Manager:

Policy files are installed and:

grep policy *
standalone.conf:JAVA_OPTS="$JAVA_OPTS -Djava.security.manager \"-Djava.security.policy=$DIRNAME/security.policy\" \"-Dkie.security.policy=$DIRNAME/kie.policy\""
standalone.conf.bat:set "JAVA_OPTS=%JAVA_OPTS% -Djava.security.manager -Djava.security.policy=%ESCAPED%security.policy -Dkie.security.policy=%ESCAPED%kie.policy"


Option (2) - Install S-RAMP and DT-GOV, user selects to NOT enable Java Security Manager:

Policy files are installed and:

grep policy *
standalone.conf:# JAVA_OPTS="$JAVA_OPTS -Djava.security.manager \"-Djava.security.policy=$DIRNAME/security.policy\" \"-Dkie.security.policy=$DIRNAME/kie.policy\""
standalone.conf.bat:rem set "JAVA_OPTS=%JAVA_OPTS% -Djava.security.manager -Djava.security.policy=%ESCAPED%security.policy -Dkie.security.policy=%ESCAPED%kie.policy"

(Statements are commented out.)

Option (3) - Install S-RAMP and NOT DT-GOV, user is not provided the option to enable/disable Java Security Manager, policy files are not installed


Note You need to log in before you can comment on or make changes to this bug.