Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057622 - webadmin: preallocated disk is reported as thinprovision in "Edit" dialogue
Summary: webadmin: preallocated disk is reported as thinprovision in "Edit" dialogue
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Tal Nisan
QA Contact: Raz Tamir
URL:
Whiteboard: storage
: 1067432 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 13:42 UTC by Dafna Ron
Modified: 2016-02-10 20:21 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:28:33 UTC
oVirt Team: Storage


Attachments (Terms of Use)
screen shot (deleted)
2014-01-24 13:42 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24532 None None None Never
oVirt gerrit 24686 None None None Never

Description Dafna Ron 2014-01-24 13:42:47 UTC
Created attachment 854980 [details]
screen shot

Description of problem:

I created a preallocated disk and when I press edit the disk is reported as thinprovision. 

storage shows that the disk is preallocated. 

DOMAIN=be5731ac-ce60-4302-ab04-99573f6799e4
CTIME=1390570205
FORMAT=RAW
DISKTYPE=2
LEGALITY=LEGAL
SIZE=20971520
VOLTYPE=LEAF
DESCRIPTION=
IMAGE=b0f8f72e-7697-4b91-9dab-4a886ce44da7
PUUID=00000000-0000-0000-0000-000000000000
MTIME=1390570205
POOL_UUID=
TYPE=PREALLOCATED
EOF

Version-Release number of selected component (if applicable):

ovirt-engine-webadmin-portal-3.4.0-0.5.beta1.el6.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a vm with a preallocated disk 
2. open the edit dialogue 
3.

Actual results:

disk is reported as thinprovision in the edit dialogue 

Expected results:

disk should be reported as preallocated in the edit dialogue
Additional info:

Comment 1 Itamar Heim 2014-01-26 08:12:12 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Tal Nisan 2014-02-17 16:22:42 UTC
Sergey, I think it's a dup of the one you fixed?

Comment 3 Sergey Gotliv 2014-02-18 16:31:22 UTC
Yes, its fixed.

Comment 4 Sergey Gotliv 2014-02-23 08:49:16 UTC
*** Bug 1067432 has been marked as a duplicate of this bug. ***

Comment 5 Sandro Bonazzola 2014-03-03 14:40:47 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 6 Raz Tamir 2014-03-18 09:19:49 UTC
Verified - followed the step to reproduce and got the expected results.

rhevm-3.4.0-0.3.master.el6ev.noarch - AV2.1

Comment 7 Sandro Bonazzola 2014-03-31 12:28:33 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.