Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057598 - Windows: CR2-2 s-ramp.bat throwing exception NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32
Summary: Windows: CR2-2 s-ramp.bat throwing exception NoClassDefFoundError: Could not ...
Keywords:
Status: CLOSED DUPLICATE of bug 1056811
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance
Version: 6.0.0
Hardware: Unspecified
OS: Windows
unspecified
high
Target Milestone: ---
: 6.0.0
Assignee: Eric Wittmann
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
Depends On: 1056765
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 12:38 UTC by Andrej Vano
Modified: 2015-08-02 23:46 UTC (History)
5 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 14:21:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrej Vano 2014-01-24 12:38:12 UTC
Description of problem:
This issue is windows-only, the exception is logged into command line when starting s-ramp.bat. Tested on Windows Server 2012, Windows Server 2012R2

This issue may be caused by fixing s-ramp path issues: https://bugzilla.redhat.com/show_bug.cgi?id=1056765

Version-Release number of selected component (if applicable):
6.0.0.CR2-2

How reproducible: 100%


Steps to Reproduce:
1. install fsw with all defaults
2. start s-ramp.bat from command line
3.

Actual results: Output in command line:

W:\avano\fsw\jboss-eap-6.1\bin>s-ramp.bat

W:\avano\fsw\jboss-eap-6.1\bin>if "Windows_NT" == "Windows_NT" (set "DIRNAME=W:\
avano\fsw\jboss-eap-6.1\bin\" )  else (set DIRNAME=.\ )

W:\avano\fsw\jboss-eap-6.1\bin>if not exist "W:\avano\jdk1.7.0_last\bin\java.exe
" goto noJava

W:\avano\fsw\jboss-eap-6.1\bin>W:\avano\jdk1.7.0_last/bin/java.exe -Xmx1024m -ja
r W:\avano\fsw\jboss-eap-6.1\bin\\s-ramp-shell-0.3.1.Final-redhat-6.jar
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$CollectionVi
ew$CollectionViewIterator.class in lib/commons-beanutils-1.8.3.redhat-3.jar is h
idden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/Buffer.class in lib/comm
ons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collections-3.2.1-redh
at-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$Values.class
 in lib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collection
s-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/ArrayStack.class in lib/
commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collections-3.2.1-
redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$EntrySet.cla
ss in lib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collecti
ons-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$CollectionVi
ew.class in lib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-co
llections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap.class in lib
/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collections-3.2.1
-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$1.class in l
ib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collections-3.2
.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$KeySet.class
 in lib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-collection
s-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/BufferUnderflowException
.class in lib/commons-beanutils-1.8.3.redhat-3.jar is hidden by lib/commons-coll
ections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/logging/impl/NoOpLog.class in lib/co
mmons-logging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redhat-1.jar (with
 different bytecode)
JarClassLoader: Warning: org/apache/commons/logging/impl/SimpleLog$1.class in li
b/commons-logging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redhat-1.jar (
with different bytecode)
JarClassLoader: Warning: org/apache/commons/logging/impl/SimpleLog.class in lib/
commons-logging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redhat-1.jar (wi
th different bytecode)
JarClassLoader: Warning: org/apache/commons/logging/Log.class in lib/commons-log
ging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redhat-1.jar (with differen
t bytecode)
JarClassLoader: Warning: org/apache/commons/logging/LogConfigurationException.cl
ass in lib/commons-logging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redha
t-1.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/logging/LogFactory.class in lib/comm
ons-logging-1.1.1.jar is hidden by lib/jcl-over-slf4j-1.7.2-redhat-1.jar (with d
ifferent bytecode)
[ERROR] Terminal initialization failed; falling back to unsupported
java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.
internal.Kernel32
        at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode(WindowsSu
pport.java:50)
        at jline.WindowsTerminal.getConsoleMode(WindowsTerminal.java:177)
        at jline.WindowsTerminal.init(WindowsTerminal.java:80)
        at jline.TerminalFactory.create(TerminalFactory.java:101)
        at jline.TerminalFactory.get(TerminalFactory.java:159)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:214)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:206)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:194)
        at org.overlord.sramp.shell.InteractiveShellCommandReader.open(Interacti
veShellCommandReader.java:55)
        at org.overlord.sramp.shell.SrampShell.createCommandReader(SrampShell.ja
va:146)
        at org.overlord.sramp.shell.SrampShell.run(SrampShell.java:90)
        at org.overlord.sramp.shell.SrampShell.main(SrampShell.java:67)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at com.simontuffs.onejar.Boot.run(Boot.java:340)
        at com.simontuffs.onejar.Boot.main(Boot.java:166)

**********************************************************************
           _____       ______  ___ ___  ________
          /  ___|      | ___ \/ _ \|  \/  | ___ \
          \ `--. ______| |_/ / /_\ \ .  . | |_/ /
           `--. \______|    /|  _  | |\/| |  __/
          /\__/ /      | |\ \| | | | |  | | |
          \____/       \_| \_\_| |_|_|  |_|_|

  JBoss S-RAMP Kurt Stam and Eric Wittmann, Licensed under the
  Apache License, V2.0, Copyright 2012
  Locale: en_US
**********************************************************************
←[1m←[31ms-ramp>←[0m

Expected results:


Additional info:

Comment 2 Julian Coleman 2014-01-24 12:58:15 UTC
The exception is caused by the removal of the native code from the jansi jar.
It does not affect the running of the server, but does result in ANSI escape sequences not being parsed in the S-RAMP shell prompts.

Comment 3 kconner 2014-01-24 14:21:12 UTC

*** This bug has been marked as a duplicate of bug 1056811 ***


Note You need to log in before you can comment on or make changes to this bug.