Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057591 - New/Edit VM dialog: VNC Keyboard Layout option is initially shown for SPICE protocol too
Summary: New/Edit VM dialog: VNC Keyboard Layout option is initially shown for SPICE p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Martin Betak
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
: 1085287 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 12:25 UTC by Pavel Novotny
Modified: 2016-02-10 19:48 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:21:36 UTC
oVirt Team: Virt


Attachments (Terms of Use)
screen of New VM dialog - Console tab (deleted)
2014-01-24 12:25 UTC, Pavel Novotny
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25483 None MERGED webadmin: Display VncKeyboardLayout only for VNC display Never

Description Pavel Novotny 2014-01-24 12:25:19 UTC
Created attachment 854937 [details]
screen of New VM dialog - Console tab

Description of problem:
When creating a new VM or editing one with SPICE console set, the 'VNC Keyboard Layout' option is displayed, although it's irrelevant for SPICE console.

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open New VM dialog -> Show Advanced Options -> Console side-tab.
2. 
3.

Actual results:
The default protocol is preset to SPICE, but below it the 'VNC Keyboard Layout' option is displayed too. See attached screenshot.
It's also possible to submit such a dialog.

Expected results:
'VNC Keyboard Layout' option is shown only when VNC protocol is set or preset.

Additional info:
This seems like a minor bug in the UI during the dialog initialization. When you change the display protocol back and forth, then the keyboard option is not shown for SPICE protocol - unless you close the dialog and open it again.

Comment 1 Itamar Heim 2014-01-26 08:10:54 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Martin Betak 2014-04-10 09:34:59 UTC
*** Bug 1085287 has been marked as a duplicate of this bug. ***

Comment 3 Lukas Svaty 2014-07-29 13:19:55 UTC
verified in ovirt-3.5.0-beta2

Comment 4 Sandro Bonazzola 2014-10-17 12:21:36 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.