Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057578 - From GuideMe link, adding Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."
Summary: From GuideMe link, adding Host using SSH PublicKey Authentication fails with ...
Keywords:
Status: CLOSED DUPLICATE of bug 1057575
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-userportal
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Yaniv Bronhaim
QA Contact: bugs@ovirt.org
URL:
Whiteboard: infra
Depends On: 1057574
Blocks: 1057575 1057576
TreeView+ depends on / blocked
 
Reported: 2014-01-24 11:58 UTC by Prasanth
Modified: 2014-01-30 16:02 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1057574
Environment:
Last Closed: 2014-01-30 16:02:31 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Prasanth 2014-01-24 11:58:03 UTC
cloning this bug for Ovirt, as the same issue is seen in Upstream Master as well.

+++ This bug was initially created as a clone of Bug #1057574 +++

Description of problem:

From Guide Me link, Add Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."

Version-Release number of selected component (if applicable): 
Red Hat Storage Console Version: 2.1.2-0.33.el6rhs (CB 15)
ovirt-host-deploy-java-1.1.2-1.el6ev.noarch
ovirt-host-deploy-1.1.2-1.el6ev.noarch


How reproducible: 100%


Steps to Reproduce:
1. Click on "Clusters" and create a New Cluster
2. Select the created Cluster and click on "Guide Me"
3. Click on "Configure Host"
4. Enter the mandatory fields and select the Authentication type as "	
SSH PublicKey"
5. Copy the key displayed in the SSH PublicKey field to /root/.ssh/authorized_keys on the host to use public key authentication
6. Click on OK

Actual results: Add Host fails with error "Error while executing action: Cannot install Host with empty password." as it's not detecting that the user has selected the SSH PublicKey Authentication instead of Password Authentication


Expected results: Add Host with SSH PublicKey Authentication should work from the "Guide Me" flow as well.

PS: It works fine in the normal Add New Host flow.


Additional info: Screenshot and log-collector report attached

Comment 1 Itamar Heim 2014-01-26 08:10:59 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Barak 2014-01-30 16:02:31 UTC

*** This bug has been marked as a duplicate of bug 1057575 ***


Note You need to log in before you can comment on or make changes to this bug.