Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057575 - From GuideMe link, adding Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."
Summary: From GuideMe link, adding Host using SSH PublicKey Authentication fails with ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Yaniv Bronhaim
QA Contact: Leonid Natapov
URL:
Whiteboard: infra
: 1057576 1057578 (view as bug list)
Depends On: 1057574 1057578
Blocks: 1057576
TreeView+ depends on / blocked
 
Reported: 2014-01-24 11:55 UTC by SATHEESARAN
Modified: 2016-11-29 18:49 UTC (History)
23 users (show)

Fixed In Version: av2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1057574
Environment:
Last Closed:
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24070 None None None Never
oVirt gerrit 24226 None None None Never

Description SATHEESARAN 2014-01-24 11:55:46 UTC
+++ This bug was initially created as a clone of Bug #1057574 +++

Description of problem:

From Guide Me link, Add Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."

Version-Release number of selected component (if applicable): 
Red Hat Storage Console Version: 2.1.2-0.33.el6rhs (CB 15)
ovirt-host-deploy-java-1.1.2-1.el6ev.noarch
ovirt-host-deploy-1.1.2-1.el6ev.noarch


How reproducible: 100%


Steps to Reproduce:
1. Click on "Clusters" and create a New Cluster
2. Select the created Cluster and click on "Guide Me"
3. Click on "Configure Host"
4. Enter the mandatory fields and select the Authentication type as "	
SSH PublicKey"
5. Copy the key displayed in the SSH PublicKey field to /root/.ssh/authorized_keys on the host to use public key authentication
6. Click on OK

Actual results: Add Host fails with error "Error while executing action: Cannot install Host with empty password." as it's not detecting that the user has selected the SSH PublicKey Authentication instead of Password Authentication


Expected results: Add Host with SSH PublicKey Authentication should work from the "Guide Me" flow as well.

PS: It works fine in the normal Add New Host flow.


Additional info: Screenshot and log-collector report attached

Comment 2 Prasanth 2014-01-24 12:06:44 UTC
*** Bug 1057576 has been marked as a duplicate of this bug. ***

Comment 3 Barak 2014-01-30 16:02:32 UTC
*** Bug 1057578 has been marked as a duplicate of this bug. ***

Comment 4 Leonid Natapov 2014-03-11 14:08:09 UTC
3.4.0-0.3.master.el6ev. host can be added using SSH from guide me

Comment 5 Itamar Heim 2014-06-12 14:06:56 UTC
Closing as part of 3.4.0

Comment 6 Yedidyah Bar David 2014-11-18 10:58:06 UTC
Now happened to me on 3.5.

Added a DC, followed the link to add a Cluster, then followed the link to add a host, failed with a message saying:

Error while executing action: Cannot install Host with empty password.

A single line was added to engine.log:

2014-11-18 12:52:18,102 WARN  [org.ovirt.engine.core.bll.AddVdsCommand] (ajp--127.0.0.1-8702-8) [457abfb6] CanDoAction of action AddVds failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__HOST,$server t123,VDS_CANNOT_INSTALL_EMPTY_PASSWORD

'Cancel' and then adding the host with the 'New' link in 'Hosts' worked.

OS is rhel 7.1 beta, engine is from upstream 3.5-snapshot ovirt-engine-3.5.1-0.0.master.20141112061952.git2c24911.el7.centos.noarch


Note You need to log in before you can comment on or make changes to this bug.