Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057574 - From GuideMe link, adding Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."
Summary: From GuideMe link, adding Host using SSH PublicKey Authentication fails with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: RHGS 3.0.3
Assignee: Sahina Bose
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1035040 1057575 1057576 1057578
TreeView+ depends on / blocked
 
Reported: 2014-01-24 11:50 UTC by Prasanth
Modified: 2015-05-13 17:40 UTC (History)
15 users (show)

Fixed In Version: rhsc-3.0.2-1.16.el6rhs.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the add host operation using the SSH public key by following the Guide Me link failed. This happened due to an incorrect authentication method being set. With this fix, hosts can be added successfully using the SSH public key.
Clone Of:
: 1057575 1057576 1057578 (view as bug list)
Environment:
Last Closed: 2015-01-15 13:47:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of error (deleted)
2014-01-24 11:50 UTC, Prasanth
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0039 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update #3 2015-01-15 18:46:40 UTC

Description Prasanth 2014-01-24 11:50:28 UTC
Created attachment 854917 [details]
screenshot of error

Description of problem:

From Guide Me link, Add Host using SSH PublicKey Authentication fails with "Error while executing action: Cannot install Host with empty password."

Version-Release number of selected component (if applicable): 
Red Hat Storage Console Version: 2.1.2-0.33.el6rhs (CB 15)
ovirt-host-deploy-java-1.1.2-1.el6ev.noarch
ovirt-host-deploy-1.1.2-1.el6ev.noarch


How reproducible: 100%


Steps to Reproduce:
1. Click on "Clusters" and create a New Cluster
2. Select the created Cluster and click on "Guide Me"
3. Click on "Configure Host"
4. Enter the mandatory fields and select the Authentication type as "	
SSH PublicKey"
5. Copy the key displayed in the SSH PublicKey field to /root/.ssh/authorized_keys on the host to use public key authentication
6. Click on OK

Actual results: Add Host fails with error "Error while executing action: Cannot install Host with empty password." as it's not detecting that the user has selected the SSH PublicKey Authentication instead of Password Authentication


Expected results: Add Host with SSH PublicKey Authentication should work from the "Guide Me" flow as well.

PS: It works fine in the normal Add New Host flow.


Additional info: Screenshot and log-collector report attached

Comment 1 Itamar Heim 2014-01-25 12:53:37 UTC
sounds similar to bug 1039253

Comment 2 Shalaka 2014-01-28 06:42:55 UTC
Please add Doc Text for this Known Issue.

Comment 3 Shalaka 2014-01-29 10:59:12 UTC
Please review the edited Doc Text and sign off.

Comment 4 Sahina Bose 2014-01-29 11:04:34 UTC
Minor edit

Comment 7 RamaKasturi 2014-11-13 12:29:21 UTC
Verified and works fine with build rhsc-3.0.3-1.17.el6rhs.noarch.

copied the key displayed in the SSH public key of New Host dialog box to /root/.ssh/authorized_keys file.

Comment 8 Pavithra 2014-12-26 07:43:27 UTC
Hi Sahina,

Can you please review the edited doc text for technical accuracy and sign off?

Comment 9 Sahina Bose 2014-12-30 05:53:09 UTC
Looks good

Comment 11 errata-xmlrpc 2015-01-15 13:47:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0039.html


Note You need to log in before you can comment on or make changes to this bug.