Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057570 - spice: console crashes when we try to open a monitor to the same vm twice
Summary: spice: console crashes when we try to open a monitor to the same vm twice
Keywords:
Status: CLOSED DUPLICATE of bug 1073461
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.4.1
Assignee: bugs@ovirt.org
QA Contact: bugs@ovirt.org
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 11:44 UTC by Dafna Ron
Modified: 2014-03-09 12:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-09 12:55:05 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Dafna Ron 2014-01-24 11:44:24 UTC
Description of problem:

I ran a vm -> opened console, once console was opened -> pressed the console button again. 
spice console crashes and we need to reload the page. 
looks like entire firefox gets stuck and we get a message that the spice plugin crashed. 

Version-Release number of selected component (if applicable):

spice-server-0.12.4-6.el6.x86_64
ovirt-engine-backend-3.4.0-0.5.beta1.el6.noarch
[dron@dron ~]$ rpm -qa |grep firefox
firefox-17.0.10-1.el6_4.x86_64
rhel-csb-firefox-config-0.1-1.el6.rhis.x86_64

[dron@dron ~]$ 
[dron@dron ~]$ rpm -qa |grep spice
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
spice-gtk-0.14-7.el6_4.3.x86_64
spice-server-0.12.0-12.el6_4.5.x86_64
spice-xpi-2.7-22.el6.x86_64
spice-glib-0.14-7.el6_4.3.x86_64
spice-gtk-python-0.14-7.el6_4.3.x86_64
spice-vdagent-0.12.0-4.el6_4.1.x86_64

How reproducible:

100%

Steps to Reproduce:
1. run a vm
2. open a spice console
3. open a spice console again

Actual results:

plugin crashes. 

Expected results:

plugin should not crash

Additional info:

Comment 1 Itamar Heim 2014-01-26 08:10:18 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:17:21 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Michal Skrivanek 2014-03-09 12:55:05 UTC

*** This bug has been marked as a duplicate of bug 1073461 ***


Note You need to log in before you can comment on or make changes to this bug.